My friend bought a Mac OS X in January 2004. Two years ago, she upgraded to Leopard. Her Mac performed OK, although it froze now and then.

Then today, she did a Software Update. She clicked upgrade, it launched, and restarted her computer. Then at around 38% done, it froze. After waiting a few minutes, she force quit and since then, her computer crashes every 20 minutes or so.

Whenever she clicks to check for software updates, she sees this error:

"The application Software Update quite unexpectedly. Max OS X and other applications are not affected. Click Relaunch to launch the application again. Click Report to see more details or send a report to Appple."

Here are her technical specs:

Mac OS X Version 10.5.7 Processor 1.8 GHZ Power PC G5 Memory: 512 MB DDR SDRAM

Hardware Overview:

Model Name: iMac G5 Model Identifier: PowerMac8,1 Processor Name: PowerPC G5 (3.0) Processor Speed: 1.8 GHz Number Of CPUs: 1 L2 Cache (per CPU): 512 KB Memory: 512 MB Bus Speed: 600 MHz Boot ROM Version: 5.2.2f4

Anyone know how to reverse a failed Software Update for OS X?


The only two options are: restore from a Time Machine backup from any or do an Archive and Install from the Leopard disc.

  • She ended up doing a Erase and Install off her old Leopard disc, after backing up all of her files. That worked - thanks! – kanamekun Aug 11 '09 at 6:44
  • An erase and install requires you to reinstall everything. Archive and Install preserves settings and profiles. – Daniel A. White Aug 11 '09 at 12:18

From your description it sounds like the 10.5.8 updater did not finish updating the system, so you may have some remains of 10.5.7 crashing the system. Before wiping out the system, or re-installing the OS try this:

Download the 10.5.8 combo updater from http://support.apple.com/downloads/Mac_OS_X_10_5_8_Combo_Update

Put it on a thumb drive, cdrom, whatever... Boot up the affected system, and attempt to install the combo updater... This will reinstall the 10.5.8 update, and hopefully resolve the issue without data loss.

Otherwise, the safest answer is to boot from the installer disk, and do an Archive and install as suggested previously...


Have her boot into safe mode and try the update.

She can boot into safe mode by holding the shift key when powering up until the grey apple appears. Safe mode can take a long time to boot.

  • She tried this and it didn't work, alas... – kanamekun Aug 11 '09 at 6:43

One possibility: boot in safe mode (hold down shift when you hear the tone) and then install AppleJack. Then boot into single user (cmd-S at the tone) and go through the AppleJack process.


It would definitely be a good idea to boot into safe mode and see if the problem persists. If it doesn't not then the problem might be some auto-loading software (which you can disable in the login items for the user account). Other things to try:

  • Create a new user account and log into that
  • Install the Combo update
  • Repair permissions
  • She also tried creating a new user account and logging into that... that didn't do the trick either. – kanamekun Aug 11 '09 at 6:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.