I currently have vim installed on my MacBook Pro via fink. I can edit files just fine in vim, but when I enter edit mode in gvim, it crashes with the following error.

Vim: Caught deadly signal ABRT
Vim: Finished.

I've tried removing config files, reinstalling vim via fink, searching forums/mailing lists for solutions, etc., but nothing has worked. Any ideas?

System Setup

  • vim (7.3.034-1)
  • fink (0.29.15 for i386)
  • gcc (4.2.1, Apple Inc. build 5664)
  • XQuartz (2.5.3)
  • Mac OS X (10.6.4)

AFAIK, there is a native Vim version for OSX called macvim. Have you tried that? Also, it would be very useful for developers of vim, that you send this as error report to them :)


What does it say in your error logs in Console.app?

A common reason for crashes in OSX is that a binary tries load another binary, and one was compiled for 32 bits and the other for 64 bits. You have to make sure the architecture options are the same for everything.

Also, make sure your vim is a stable release.

  • Application Specific Information: abort() called, USING_FORK_WITHOUT_EXEC_IS_NOT_SUPPORTED_BY_FILE_MANAGER. This is a stable release, compiled from source via fink. – Garrett Hyde Oct 29 '10 at 2:28
  • It looks like there's an issue with the source. – Garrett Hyde Oct 29 '10 at 2:34
  • Also, recompiling vim in 32bit and 64bit mode doesn't fix anything. I still get the same crash report. – Garrett Hyde Oct 29 '10 at 2:55
  • It looks like a bug that is unique to Snow Leopard. – Jay Oct 29 '10 at 4:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.