I have 2 Apple Time Capsules and one gigabit airport extreme for 3 stations total. All support 802.11a/n-802.11b/g/n. It is absolutely beyond me how to set this up effectively as a single wireless network.

Here are some facts about the network I have:

  1. There is good ethernet throughout the house connected to a central area where a cable modem is located.

  2. There are 5 computers, 2 Apple TV's, and several printers connected by ethernet to the network. There are three computers and several iPhones, iPod Touchs and iPad connecting wirelessly (or attempting to...)

  3. There are several airport express stations connected in wired-only mode to act as media or print severs.

  4. I am using one of the time capsules as the router to the outside world connected to the cable modem. Let's call that "MAIN TC" time capsule. MAIN TC is also a DHCP / NAT server to the wired and wireless network.

  5. The MAIN TC is at one extreme of the house. There is an Airport Extreme in the middle that has fair to poor access to MAIN TC wirelessly but good access to ethernet. There is another time capsule at the extreme end of the house that has fair to poor access to the airport in the middle and no access to MAIN TC wirelessly but again is connected to ethernet.

  6. Everything connected to ethernet is on the same sub net. MAIN TC is the DHCP server. Any ethernet connected device can see any other ethernet connected device at gigabit speed. The far ends cannot see each other wirelessly.

  7. The wireless network is protected with WPA2 Personal and there is no MAC access control set up.

I want to be able to use the wireless and wired network seamlessly to control media with iPhones and iPads with the Apple remote app and to have wireless and wired Internet access. Simple requirement!

Here are the things I have tried and how those things failed:

  1. I tried to set up the network with WDS. The newer time capsules seem that they no longer support WDS as the older airport express base stations did. Strike 1.

  2. I tried to set up MAIN TC in the Create a wireless network wireless mode. Then I set up the other two base stations as described on P. 43 of the Early 2009 Airport Networks manual. It is not clear to me, but is seems that even though the remote base stations are connected to ethernet, they actually share the connection wirelessly and ignore ethernet entirely. This causes a tremendously slow wireless network because the base stations can only 'see' the station in the middle. Also, MAIN TC seems to get so confused that access to the Internet fails wired and wirelessly. Extremely unstable. Strike 2.

  3. I tried setting up each base station as its own uniquely named base station with connection sharing set to bridge mode in the two stations other than MAIN TC. This works kinda. The problem here is that the iPhones and iPads will establish a connection with one WI/FI station and try and keep that connection even though another base station is a lot closer. Once the new base station kicks in, the Apple Remote app loses all its cache about music and you need to reload the catalog of music and outlets. Annoying enough to render one of the goals nearly useless. Let's call that Ball 1

So my question is: Is there a way to do this that I am missing?

(PS: Go Giants!)


Not quite your situation, but I've got four AirPort Expresses and all are set to "Create wireless network," all have the same Wireless Network Name, and all have "Bridge Mode" on. I use a separate router for DHCP and that router is connected to the Internet, not any of the access points.

Even though my setup is different, you should be able to setup the MAIN TC to handle DHCP and the Internet connection, and then have the other access points setup as above. Have you tried that?

  • I did, and it was kinda like "3" but I will try again. Thanks!!! – drewk Oct 29 '10 at 23:55
  • So I set it up the way you describe and it seems to be working. Each stations states connection by ethernet and the network is not bogging down. The iPad and iPhones still try to hang on the old station too long. I think I will try dialing down the signal strength to address this. THANKS MATE!!! – drewk Oct 30 '10 at 2:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.