I can't delete a certain folder in Windows 7. It's not a system folder. It was created by an app. I get an error message "You need permission to perform this action. You require permission from Tony....". I am an admin and logged in as myself Tony. I have full ownership of the folder with full control permission. I rebooted the machine. I killed the app which created the folder. I am out of ideas.

Why is Windows 7 not letting me delete the folder?

  • Have you got any background processes: TortoiseSVN, Anti-virus softwares, etc. that might be hanging on the folder (though I agree this is unlikely after a reboot). Alternatively have you tried deleting it while in safe mode? – PeterJCLaw Oct 29 '10 at 18:33
  • No idea why, but if safe mode deletion doesn't work, you could boot your system from a live CD of some sort (like Linux) and go directly into the file system and delete the file. This would undoubtedly work, but if some process is actually using the file, then it might break that process (when you reboot into Windows) with unknown consequences for the rest of your system, so make a backup of the file so you can put it back if things start to go south. – Joe Feb 11 '13 at 19:47
  • Just a thought: What are the attributes of the folder and everything under it? If something is set to read only (or maybe system), then you would probably have to remove those attributes before you could delete it even if you own it and are an admin. I haven't worked at that level in Windows for a long time, but that's how it used to work. – Joe Feb 11 '13 at 19:54
  • You are not an administrator. You are said that you have his rights. Wrongly. The receipt is very simple, look this answer below: superuser.com/a/1119561/134259 – Gangnus Feb 6 '17 at 12:49
  • 3
    I am in the administrators group. – Tony_Henrich Feb 7 '17 at 16:14

14 Answers 14


I am not sure why this happens but there is a workaround.

To take control of the folder containing the undeletable create a text file called “delete.bat” and add the following lines to it:

SET DIRECTORY_NAME="C:\Locked Directory"
ICACLS %DIRECTORY_NAME% /grant administrators:F /t

You will need to change the directory path to match your requirements e.g. “C:\Locked Directory” to “C:\Delete Me”.

Right click on the file “delete.bat” select “Run As Administrator” and you should now have full control of the directory and all sub directories meaning you can do what you wish with them.

| improve this answer | |
  • 56
    Tried it but it didn't work. – Tony_Henrich Oct 29 '10 at 18:20
  • 1
    That is a bummer. I was faced with a similar issue on a Windows 7 (64 bit) machine and this worked like a charm. – Sahil Oct 29 '10 at 21:26
  • 6
    It would have been nice if Microsoft fixed this bug in Sp1. This is a massive fail, and I curse each time I have to delete deep nested directories. – ozczecho Apr 7 '11 at 6:12
  • 1
    +1 I had two system owned folders on a secondary drive that were created by the OS prior to my Win 8 -> 8.1 upgrade. Even through the Advanced Security dialog (MS's preferred approach), I could not take ownership to delete. This worked like a charm. – Joseph Ferris Sep 20 '13 at 14:49
  • 1
    Windows 8.1 - Files & Folders were created remotely through SMB, only this was able to take ownership. Afterwards I still could not remove the files (Error message told me to get permission from myself) but the Advanced Security Dialog was THEN able to fix the permissions using the inheritance clean-up checkbox. After this I could remove the files. – dualed Jun 11 '15 at 6:31

The only way was to delete files starting from the lowest level folder in that folder. I got that error message with every folder which had subfolders. I deleted all files/subfolders working my way up.

| improve this answer | |
  • 13
    That's the only thing that worked for me as well. – BioGeek Apr 5 '12 at 10:06
  • stackoverflow.com/questions/1293398/…. have a look here. worked for me – tigrou Sep 15 '12 at 12:57
  • 6
    Try this: Properties -> Security -> Advanced. Ensure the owner is assigned full control permissions. Change Permissions, check "Replace all child object permissions...", Apply. Now try to delete. The analog solved same problem for me under Win8, if certain details are slightly different. – wilee Nov 24 '12 at 17:37
  • 3
    why does this occur? – Jason S Jun 1 '16 at 18:42
  • 12
    I can't do this because "Access is denied" when trying to open it. – User Dec 8 '16 at 17:12

A folder can disallow a parent from overwriting its permissions, so it stops working at a certain depth.

Use Process Monitor and filter for ACCESS DENIED events to figure out this depth

Every time an ACCESS DENIED event occurs change the permissions as explained by @Sahil.

You can use Handle too see what processes are opening files within your folder.

handle C:\Path\To\Folder\You\Are\Trying\To\Delete


C:\Windows\system32>handle C:\Windows\System32\inetsrv

Handle v3.45
Copyright (C) 1997-2011 Mark Russinovich
Sysinternals - www.sysinternals.com

svchost.exe   pid: 1500  type: File  134: C:\Windows\System32\inetsrv\config\schema
svchost.exe   pid: 1500  type: File  1B4: C:\Windows\System32\inetsrv\config\schema
svchost.exe   pid: 1500  type: File  1BC: C:\Windows\System32\inetsrv\config
svchost.exe   pid: 1500  type: File  1CC: C:\Windows\System32\inetsrv\config
svchost.exe   pid: 1500  type: File  1D0: C:\Windows\System32\inetsrv\config
inetinfo.exe  pid: 1572  type: File  3C:  C:\Windows\System32\inetsrv\en-US\inetinfo.exe.mui
inetinfo.exe  pid: 1572  type: File  188: C:\Windows\System32\inetsrv\MBSchema.bin.00000000h
inetinfo.exe  pid: 1572  type: File  190: C:\Windows\System32\inetsrv\MBSchema.bin.00000000h
inetinfo.exe  pid: 1572  type: File  1BC: C:\Windows\System32\inetsrv\MetaBase.xml
inetinfo.exe  pid: 1572  type: File  1D4: C:\Windows\System32\inetsrv\MBSchema.xml
svchost.exe   pid: 1884  type: File  1AC: C:\Windows\System32\inetsrv\config\schema
svchost.exe   pid: 1884  type: File  1C0: C:\Windows\System32\inetsrv\config
svchost.exe   pid: 1884  type: File  1C4: C:\Windows\System32\inetsrv\config
| improve this answer | |
  • 1
    This is a good tip. My problem was that I wanted to delete a folder, but I got an Access Denied error. The folder properties showed that I had no permissions to even change the ownership of the folder. I used Process Explorer and used the Find Handle search to find which process had a handle to the locked directory. Then I killed the process, and everything was working again. – Mas Nov 27 '12 at 15:03
  • 5
    Using handle command in cmd line is the only thing that worked for me! – Steven Xu Nov 18 '14 at 3:07
  • 1
    Thank you for your answer. handle utility helped a lot – Sharikov Vladislav May 11 '17 at 9:55
  • 1
    The handle program was wonderful. – MxNx Oct 5 '17 at 20:51
  • Worked great in Windows 10 too :) – Doug McLean Oct 31 '17 at 9:53

Had this issue today with a Windows Update folder and would like to supplement the answer.

When permissions on a folder are correct (example below, with Admin being the administrator account I was logged in with):

enter image description here

But permissions on subfolders are different and do not propagate from the parent even though you tell them to, causing problems when trying to delete the parent folder:

enter image description here

Open a command prompt (personally, I did not need to elevate the prompt) and run

ICACLS <FolderName> /reset /T

enter image description here

To replace Access Control Lists with default ACLs, traversing all subfolders. After this try deleting the folder.

| improve this answer | |
  • 3
    Still doesn't work for me: "Accès refusé." which mean "refused access". Thanks anyway, what a pain to get "root" access on windows pffff.:/ (I was in a command line started as administrator) – pdem Jan 9 '16 at 18:56
  • 1
    I'm getting handle is invalid error. Any idea what that means? – James Draper Feb 5 '17 at 18:31
  • Windows 10 Enterprise. Worked for me! – Miloš Ljumović Mar 7 at 2:29

I had this issue and tried several of the answers here to no avail. However, I was able to simply delete the entire folder I was having problems with from an elevated command prompt like so:

rmdir "C:\path\to\folder" /s

Hope this helps someone.

| improve this answer | |
  • This is exactly what I did too... can't believe I had to look through every answer to find someone else who did the same thing. IMHO should be the first thing anyone tries. – u8it Oct 20 '16 at 1:35
  • Yes, this works, but you have forgotten to mention, that you should open the cmd window as an administrator. It is NOT the same as being a user with rights of administrator. – Gangnus Feb 6 '17 at 12:46
  • 4
    Opened CMD as administator, but still: C:\ws>rmdir "C:\ws\preact-material-components" /s C:\ws\preact-material-components, Are you sure (Y/N)? y Toegang geweigerd. (access denied) – Stijn de Witt Apr 28 '18 at 14:11
  • 3
    Still gives me "Access is denied" – TrojanName Dec 12 '18 at 12:11
  • 1
    Combining this with another answer's suggestion of icacls foldername /reset /T worked for me. (I'd earlier also taken ownership of the folder) – M.M Jan 15 at 1:52

download SysInternals Suite and use the following utilities

use Process Explorer and Process Monitor to find out whats happening with your file

or use the following stand alone utils

use AccessChk to get details not easily available via the GUI

use PSFILE to scan for any process that is holding the file open then try the MoveFile utility to schedule a file delete in the next boot cycle.

The answer you're looking for will show up in the output of one of these utilities

| improve this answer | |
  • Process Explorer has just helped me out with exactly this problem - great tool. – zifot Dec 20 '11 at 20:19

When I run into a folder/file I can't delete and rebooting doesn't free the file. I will add to the security setting of the file/folder the Everyone group and set the permissions to Deny Full Control. Then when I reboot the machine, what ever was using the file/folder starts, it won't be able to read/write or lock the file/folder. Finally with nothing being able to use the file/folder, you will be free to delete it.

Hope this helps.

| improve this answer | |

No go with Windows 7 Ultimate x64. Finally had to boot from a USB-based linux OS (which ignores file permissions in NTFS file systems) and delete the offending directory that way.

| improve this answer | |
  • 1
    That's a bit much for a Windows user (even though I suggested the same thing before I read your answer ;) ), but an rm -rf of the subdirectory tree is sure a lot faster than the other methods! The issue is that something could break when Windows starts up again and the offending process or whatever can't find the folder/files. – Joe Feb 11 '13 at 20:05

You can use Unlocker utility to delete such folders.

It is very simple to use and it is completely free.

| improve this answer | |
  • To be specific the software is IOBit Unlocker - the above link is an affiliate link. This suggestion worked perfectly for me on Windows 10 to delete a domain user locked download. – robertmoggach Jan 28 '19 at 19:44
  • @mogga: I'm pretty sure the link would have changed in the last 5 years now. – ani627 Jan 29 '19 at 13:44
  • Every other solution didnt work. It was locked completely. IOBit savec my ass. – Fredy31 Feb 27 at 19:08
  • 1
    I tried most of solutions , like trying to use 'TAKEOWN' command , trying to change file permissions etc etc , however all I was getting was 'Access denied' error . Moreover when I tried listing group & owner of that folder (which was corrupted) through cygwin on windows , I was getting 'Unknown' user & group [drwxr-x--- 1 Unknown+User Unknown+Group 0 Sep 11 06:14 bin] . I tried using IOBit Unlocker & that worked like charm , it unlocked that folder & afterwards folder got deleted automatically . – sjethvani Sep 11 at 13:43

I assume UAC is enabled and you are trying to delete the folder from Windows Explorer. You should run Windows Explorer as administrator (right click on the icon and select "Run as administrator") and then delete the folder.

The other alternative is to disable UAC, but I wouldn't recommend it.

| improve this answer | |
  • 1
    UAC is off and I am logged in as admin. I tried your method and still same problem. Plus UAC is just a warning and if you say Yes, it continues with its process. – Tony_Henrich Oct 29 '10 at 18:13
  • @Tony UAC does actually do some other things. I have some legacy applications that won't run under Windows 7 with UAC turned on even if you accept the prompts (in fact, even if you have the prompts turned so low you don't get any running these apps!) I really wish I knew WHY this is, but it is. – Shinrai Oct 29 '10 at 18:53

Well, this happens for files that were installed by some kind installer, like under the TrustedInstaller user.

You need to pwn the file first,

  1. Right click the file, go to Properties/Security/Advanced.
  2. Owner tab/Edit/Change the owner to you (Administrator), save.
  3. Now you can go back to Properties/Security/ and assume Full Control over the file
| improve this answer | |

Try moving the folder to your Desktop and deleting it there, odd, but has worked for me under similar circumstances.

| improve this answer | |

I had the same issue (Windows required permission from user X, while being connected as user X…):

enter image description here

I fixed it using unlocker (free, Microsoft Windows), then did:

enter image description here

enter image description here

After that, I could delete the directory without further issue.

| improve this answer | |

I had the same I issue and wasn't able to change any permissions, regardless of the tool used.

It seemed that the folder didn't really exist anymore but was somehow still there. So what worked for me:

Create a new folder with the same name in the containing directory.

Normally you'd expect a "directory already exist" but in my case it merged with/replaced the broken folder and I was able to delete it afterwards.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.