16

When I run revert-buffer in emacs it says:

You can run the command `revert-buffer' with s-u

I've never seen any keybinding beginning with s- before. What key is that?

My emacs version is GNU Emacs 23.2.1 (x86_64-apple-darwin, NS apple-appkit-1038.29) of 2010-05-08 on black.local

Update: Now I see why I didn't understand s-u. It is something added by aquaemacs. The first thing I did after installing aquaemacs was (setq mac-command-modifier 'meta) to make it work the way I expect.

1
  • Re update, I never installed aquaemacs on my mac. I use plain emacs 25.* with no gui, yet I get the s-u. I tried "command-u", all I get is a bell sound. Commented May 10, 2017 at 9:39

1 Answer 1

9

It's the Super Key, similar to Meta. More information in this StackOverflow answer.

1
  • 2
    By default, Emac's super key is bound to apple's Command key on for emacs built with the NS or NextStep option. At least that was the case on my copy. Commented Oct 30, 2010 at 0:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .