I am trying to work with the latest version of Gnu Emacs on my Mac.

I installed emacs (install emacs) using MacPorts and it is working but without the GUI ... Is there a special thing to install (like an another port including the gui) or a special command to launch it properly ?

I also tried the same under X11 without success.

If it is not possible to make it work like that, is there another way ? I read about Aquamacs but apparently it is not a port of Gnu Emacs, but it is just loosely based on Gnu Emacs.'

Any help and advices are welcome !

Thanks (and I hope my question is clear enough).

2 Answers 2


Did you build it with the +gtk variant? Use port info emacs and port variants emacs to see that there is a gtk and motif variant that provide a GUI through X11. Also check out the emacs-app port, which is an OS X Cocoa version.

  • Thanks ! In the info of emacs-app they say "It differs from Carbon ports of GNU Emacs in that it makes a more concerted attempt from the ground up to follow OS X desktop and UI conventions." Ok; but which one is the Carbon one ?
    – Cedric H.
    Oct 30, 2010 at 16:16
  • @Cedric Not sure.
    – fideli
    Nov 2, 2010 at 0:39

I wouldn't really call Aquamacs a port of GNU/emacs ... it's just simply an extension of it to make it more Mac like -- it is still very much emacs.

That having been said, you can get a perfectly "clean" build of emacs 23.2 without going through here:


You'll get an Emacs.app which you would use like any other application, but it's pure, 100% emacs.

  • OK, Thanks ! I tried this .app and finally I also managed to have it with Mac Port.
    – Cedric H.
    Oct 31, 2010 at 13:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .