I am moving some old folders from my Mac PowerBook Pro to a UNIX network drive. In doing so I was getting a few "all files could not be copied" errors which I ignored, thinking it was aliases which were causing the problem. Silly me, it was worse than that, because now I notice that some of the folders I copied are empty on the network drive I copied them to. And I've already deleted the folders from my laptop.

No problem, I thought, I've got Time Machine. I went back in time a month and tried to restore the folders that didn't get copied correctly. But that results in an error saying I don't have permissions to copy the files from Time Machine back to my laptop.

Is there a way "sudo" a restore from Time Machine?

In the meantime, I am checking and repairing permissions on my TM disk. We'll see if that changes anything.

Resolution Thanks for the answers! The issue was that extended attributes were not being copied from the external HD to the network drive. This may have something to do with the respective filesystems and is described in this post to Apple's support forum.

The files in question were symbolic links, which perhaps have external attributes which make them work just like Mac aliases.

Using cp on the command line did exactly what I needed to. I had no idea there was a CLI for that. It still complained about the external attributes but at least it copied the files. They still function as symlinks on the network drive.


Not sure how you can resolve those permission problems using the TimeMachine UI, but I'd guess using the Terminal would work.

Ref: http://discussions.apple.com/message.jspa?messageID=10394853

cp -R TimeMachineSourceFolder WhereYouwantTheFilesRestored


cp -R /Volumes/BACKUP/Backups.backupdb/MK\ MBP/2009-09-29-141056/Macintosh\ HD/Users/yourself/Documents "/Users/yourself/Documents"

To find a source folder you can restore, you should be able to browse your TimeMachine backup in the Finder, then drag and drop the folder you want to restore into Terminal, to paste it's full path there.

If you still get permissions problems during the cp operation, just prefix the whole command with sudo:

sudo cp -R TimeMachineSourceFolder WhereYouwantTheFilesRestored

Good luck.


To invoke "Enter Time Machine" as root, you'll need to run Finder as root:

sudo /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.