I have a Belkin "ADSL modem with wireless-G router".

There are four PC's/Laptops in my house that have been connecting to it without problem for many months. Unfortunately my bandwidth usage has suddenly rocketed and I'm having to pay extra to my ISP. I suspect that a neighbour may be stealing my bandwith. I was using 128 bit WEP, bit thought I should change to "WPA".... now I say just "WPA", but it seems there is a minefield of different names and variations. For a start my belkin control panel gives me the choice of "WPA-PSK (no server)" and "WPA with radius server". Someone told me to use the former. Which I have now selected, set up a password and saved the settings.

Now I want to connect my windows7 laptop wirelessly to the router. If I look at the available list of wireless connections, I see the name of my network, but it now has a red cross next to it. Clicking on the name tells me that the setting do not match. I was hoping that I was going to be told that the security method had been changed and I just need to type in a new password... but it gives me no clues... So I thought that perhaps I need to configure the setting from scratch... but now there are a bewildering array of choices of settings... starting with a lot of different names of security systems, "WPA-personal", "WPA2-enterprise" etc. I've tried a few guesses, but when I guess I then get given even more choices, like setting the "encryption type" (AES) or (TKIP)... so my chances of guessing everything are slim.

Can anyone tell me how I can configure my laptop to talk to my modem?


Keep it at WPA + WPA2 with AES.

(Note: The screenshot is from my router since you haven't mentioned your router model.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.