When I boot up my PC (duel boot with Vista, which works fine) and go to ubuntu in the grub menu I get an almost immediate kernel oops. Errors include (from memory)

  • /dev, /proc & /sys doesn't exist
  • /sbin/init doesn't exist

The oops dumps a Call Trace which looks to be knee-deep in ext4 modules.

So I booted the normal desktop live CD for 10.10 and tried to mount the ext4 partition from there. All of the utilities which I used to try to access the partition failed to complete, they just hang. These include mount on the command-line and the Disk Utility found under the live CD's Administration menu.

The BIOS has a low-level scan which reported that the hard drive is physically OK. I confirmed this by successfully booting the Vista partition.

The other weird thing is that I didn't do anything to the machine while it was still working to prompt it not working anymore. No messing around with file systems, no partition resizing or anything risky at all. Was just using it the day before for watching movies.

Is there anything I can try to recover some of the files on there?

  • I tried using the ubuntu rescue remix. Kernel oopsed with the same stack trace. running e2fsck -v /dev/sda6 replied with 'device or resource busy' Nov 4, 2010 at 8:10
  • Have you run a memory test recently? (Select it from the boot prompt, let it run for a few hours, preferably just after a crash when the RAM modules are hot.) Check /var/log/kern.log, either on the actual system (if you manage to mount it) or on the live CD, for information about what caused the crash or hanging access. Don't hesitate to post any message you see there that you don't understand. Nov 4, 2010 at 21:14
  • I booted with the SLAX rescue disk and ran e2fsck on the partition. It reran the journal and fixed one or two things and now the problem is gone. Weird... Nov 5, 2010 at 8:24


You must log in to answer this question.

Browse other questions tagged .