7

I am using Excel 2004 for Mac Version 11.2 on Mac OS X 10.4 (Tiger) right now.

I cannot for the life of me figure out why it insists on using commas to represent decimal places. Does anyone know how to change this to periods?

1
  • 1
    Sounds to me like a localization problem. I.e. in Europe, a dot is used, in american language setting a comma. Not sure how to change it though.. – pgruetter Nov 4 '10 at 11:23
8

Go to:

System Preferences -> International -> Input Menu

Check off

Show input menu in menu bar

Look up in the menu bar, and make sure the country selected is correct for you ( Assuming US ). If it's set for a different country, you may see this issue. I believe if your input is set to German, for example, it will exhibit what you describe seeing in Excel.

EDIT: details on solution from @sixtyfootersdude:

This is what my international panel looks like. You can see that there is a little warning there. Here is what resolved the problem:

I changed the Region to US I closed the panel I opened excel (everything is now using periods) I quit excel I reopened the international panel I changed the region back to Canada Apparently this solves the problem.

alt text

1
  • Cool, thanks for the help. Your answer helped me to figure out how to solve this. If you copy and paste my answer into yours I will accept your answer. – sixtyfootersdude Nov 4 '10 at 12:16
1

In Mac OS X 10.10 (Yosemite): System preferences -> Language and Region -> Region: United Kingdom (or another country that uses dots to represent decimal places).

0

This is what my international panel looks like. You can see that there is a little warning there. Here is what resolved the problem:

  1. I changed the Region to US
  2. I closed the panel
  3. I opened excel (everything is now using periods)
  4. I quit excel
  5. I reopened the international panel
  6. I changed the region back to Canada

Apparently this solves the problem.

alt text

0

I am using Microsoft Excel 2016 on MacOS Sierra. I can change semicolons to commas successfully by doing the following steps:

  1. Quit all Microsoft Office Application
  2. Open System Preference
  3. Select Language & Region
  4. When the Language & Region Panel appears you change Region to United State (Computer)
  5. Open Microsoft Excel and type any formula. You will see the semicolon in the formula changes to commas.

enter image description here

1
  • This works but I am forced to use US as region. – Herman Toothrot Nov 12 '19 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.