4

How can you make Irssi system-beep without PC speakers?

I know this post. I have now also my PC speakers connected to my computer in the case that the sound starts to work with them. However, this should not be necessary, since I should get the same sound as with beep witout these PC speakers.

My Irssi does not beep when my name is mentioned, although I put the following codes to my Irssi in Ubuntu

/set bell_beeps ON /set beep_msg_level MSGS NOTICES DCC DCCMSGS HILIGHT 

and

/set bell_beeps = ON 

I use Audible Beep also tried to set by CTRL-A CTRL-G.

5
+50

I answered a related query here. On a similar vein, can you try the following:

  • Check if pcspkr module is currently loaded

    $ lsmod | grep pcspkr
    pcspkr 10496 0

  • If it is not, check if it has been blacklisted:

    $ sudo grep pcspkr /etc/modprobe.d/blacklist*
    /etc/modprobe.d/blacklist:blacklist pcspkr

    If you find such an entry, remove it and reboot.

  • If it hasn't been blacklisted, check if the system speaker was identified properly at boot and if there are any related errors in /var/log/dmesg

    $ sudo grep pcspkr /var/log/dmesg
    [ 15.620198] input: PC Speaker as /devices/platform/pcspkr/input/input8

  • If it there are no errors in /var/log/dmesg, grep all other logs in /var/log/* with today's timestamp.

I'd also check Irssi to ensure it's not been configured to mute sounds.

| improve this answer | |
0

Is system beep disabled on your system? From a terminal, type beep and see if you get a beep from your PC speaker.

| improve this answer | |
0

Try with Fancy Beeper Daemon. I found a blog post that talks about setting it up, specifically with irssi and screen.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.