3

Sometimes when I am working with remote sources on netbeans, if the connection fails, netbeans will open up a little window with a prompt that says something like "Remote synchronization failed, do you wish to disable remote synchronization for this session?"

When this comes up, there are two options:

1) Click yes, which would mean EVEN AFTER I fix my connection problems, netbeans will still refuse to auto remote synch until I restart the editor.

2) Click no, which would cause netbeans to try the sync again (obviously failing) only to have the prompt show up again.

This is really annoying. Sometimes I know I have a connection problem, but it is kinda hard to FIX said problem with this prompt showing up once every 5 seconds (stealing away keyboard focus as well).

Is there a way to disable the prompt?

1
  • Either set to upload manually in run configuration, or don't use netbeans. There are tons of overly opinionated options that you can't really turn off very well in netbeans. Remote sync also can't be stopped after it begins uploading something, such as a gigantic cache directory it decided to ignore that you set as an ignored folder for example. Generally upload on save is going to cause you much more headaches than just right clicking the file and selecting upload on occasion.
    – mopsyd
    May 8 '18 at 6:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.