140

Is there a way, using the keyboard, to switch from a maximized (full screen) Remote Desktop Connection back to the main computer?

I have about 4 Remote Desktop connections that I am switching between and it would be nice to not have to go to the mouse each time I want to switch.

I know I can press Ctrl+Alt+Break and that normalizes the remote desktop screen. That is close, but I would like a way to just minimize it (so I don't have to normalize->switch->maximize each time I want to switch screens)

14 Answers 14

92

CTRL + ALT + BREAK will un-maximize the fullscreen connection window on the host PC.

4
  • 8
    For me that just "Normalizes" it. But that is good enough. (Alt + Tab can then be used.)
    – Vaccano
    May 4, 2012 at 15:52
  • 8
    For me, a second ctrl-alt-break will re-maximize the window.
    – Ben Mosher
    Nov 13, 2012 at 19:05
  • 4
    CTRL + ALT + PAUSE also works if you don't have the BREAK key or if have to type FN to reach BREAK.
    – hobbes3
    Feb 4, 2014 at 16:00
  • 1
    ctrl + alt + pause doesn't work with MS sculpt keyboard (Windows 8). Jun 18, 2014 at 2:15
70

Ctrl + Alt + Home will bring focus to your local machine (at least in Win 8). Ctrl + Alt + Home then Win will open the windows menu on your local machine.

With virtual machine use, I often have multiple RDP sessions open, and switch by Ctrl + Alt + Home then Win + T then arrow keys to pick the RDP session I want to be in.

7
  • 6
    After pressing Ctrl + Alt + Home, in Windows 10, I can use Alt + Tab in local machines
    – Harun
    Jul 11, 2018 at 6:47
  • 2
    Perfect solution for people without a Break and also no Pause button
    – bugybunny
    Nov 7, 2019 at 8:23
  • 2
    I can understand that it is an old thread, but I think the now this answer should be marked as accepted answer so it is easy for first time visitor like me to get to actual solution. Thanks Apr 8, 2020 at 7:59
  • 1
    There is one problem - if I use alt-tab after this sequence and then alt-tab to return to the remote session, the cursor isn't focused inside the remote machine, and so keyboard commands keep being sent to the local machine. Anyone found key sequence to focus back into the remote session?
    – Shovalt
    Feb 8, 2021 at 14:06
  • 1
    @Shovalt I'm only able to reproduce this problem if the remote sessions is not maximized, so Win + Up Arrow seems to take care of it.
    – Brian Z
    Jun 27, 2021 at 14:46
23

This bugged me for the longest time as well.

Initial attempts to solve it with AutoHotkey failed, because the Remote Desktop client installs a keyboard hook and swallows all input.

I finally discovered that the Caps Lock key gets passed through to the local system.

So, this AutoHotkey script will do the trick, making Ctrl+Shift+CapsLock minimize Remote Desktop:

#IfWinActive ahk_class TscShellContainerClass
  ^+CapsLock::
    ; Need a short sleep here for focus to restore properly.
    Sleep 50
    WinMinimize
  return
#IfWinActive

Corrected version that works for me:

#IfWinActive ahk_class TSSHELLWND
  ^Capslock::           ; Ctrl+Caps Lock (couldn't make Ctrl+Shift+Caps Lock work for some reason
    ; Need a short sleep here for focus to restore properly.
    Sleep 50
    WinMinimize A    ; need A to specify Active window
    ;MsgBox, Received Remote Desktop minimize hotkey    ; uncomment for debugging
  return
#IfWinActive
3
  • Same issue as dnk.nitro on Win7 64-Bit. Upon changing the ahk_class Ctrl+Shift+CapsLock works for me.
    – koushik
    Jun 4, 2014 at 9:59
  • This did not work for me under Windows 10 because of #IfWinActive did not detect the remote desktop. I used the spy to try several different detection methods. So I removed the #IfWinActive line and it works! Of course, it now minimizes all apps, not just remote desktop, but i can live with that.
    – Knox
    Oct 27, 2017 at 17:27
  • 3
    For me on Windows 10 I had to change IfWinActive to #IfWinActive Remote Desktop Connection ahk_class TscShellContainerClass and put SetTitleMatchMode, 2 at beginning so it checks if window title contains "Remote Desktop Connection" text
    – CichyK24
    May 24, 2018 at 13:14
13

It is possible to use the normal, comfortable, Alt+Tab keyboard shortcut to get out of a full screen Remote Desktop, but requires a slightly different setup before connecting. Instead of minimizing the remote system, I just switch to another local program and leave the remote system in the background with the following:

  1. Before connecting to the remote machine with Remote Desktop Connection, on the "Local Resources" tab, I set "Keyboard" to "On this computer". This allows using Alt+Tab to get you back to any other program on the local system.enter image description here
  2. When I want to switch between programs on the remote system, I use Alt+Page Up, which works just like Alt+Tab would, but only on the remote system.

In addition, you can use Alt+Page Down (or Alt+Shift+Page Up) to cycle through the active programs on the remote system in reverse.

One caveat Luc mentioned should be pointed out: using this setup, all keyboard shortcuts using the Windows Key are sent to the local system. An example would be Windows Key+E to open Windows Explorer, which will get you to the local file system, not the remote one.

It took a short amount of time to get used to, but this setup has worked well for me without the need for additional software or more than one shortcut.

4
  • Very good to know this, though it doesn't direct all other input to the remote machine. Using windowskey+E for example is performed locally. +1 anyway.
    – Luc
    Mar 27, 2013 at 8:29
  • @Luc - That is a side effect I should have mentioned - I'll add that to the answer. It can be helpful or frustrating always having the Windows Key local depending on what you want at the moment. Thanks.
    – kevinmicke
    Mar 27, 2013 at 15:35
  • This is exactly what I'd want, but I'm not sure how to configure it. Here there's a link in browser that opens the client so it's impossible configure anything before that. And just opening the citrix client asks for some email which never resolves to anything. Would there be any way to configure this? Maybe some config file on my pc I can edit?
    – T_D
    Jan 28, 2016 at 11:07
  • @T_D - Off hand I'd guess you won't be able to control it if you're only able to access it through a browser, and I haven't used Citrix myself. While they may not help, a couple places to try would be: 1. C:\Users\YOUR_USERNAME\Documents\Default.rdp where you'd want to change to "keyboardhook:i:0" 2. If that doesn't work, you could try the same setting under here in the registry: HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default (found here msdn.microsoft.com/en-us/library/… ). Good luck!
    – kevinmicke
    Jan 29, 2016 at 18:48
6

For me in Windows 7 64 bit to make scrip work I had to change 1st line from #IfWinActive ahk_class TSSHELLWND to "IfWinActive ahk_class TscShellContainerClass so the full script now looks like:

#IfWinActive ahk_class TscShellContainerClass
  ^Capslock::           ; Ctrl+Caps Lock (couldn't make Ctrl+Shift+Caps Lock work for some reason
    ; Need a short sleep here for focus to restore properly.
    Sleep 50
    WinMinimize A    ; need A to specify Active window
    ;MsgBox, Received Remote Desktop minimize hotkey    ; uncomment for debugging
  return
#IfWinActive
1
  • This worked perfectly for me in Win7 Ultimate 64-bit bootcamp on a Mac. Thanks!
    – John B
    Mar 10, 2015 at 16:08
5

Not quite what you asked for, but might be helpful enough:

CTRL + ALT + - switches you to the host computer

CTRL + ALT + - switches you back to the remote computer

Source

3
  • 1
    Yes, but this does not work if you chose to not propagate all keys to the remote machine. I need that to have some keyboard shortcuts in the remote machine. The combinations mentioned by the OP do work even in this case, with the flaws mentioned.
    – Marcel
    Jan 5, 2011 at 15:32
  • 4
    Hope people trying this solution do not have intel graphics card :D
    – anishsane
    Jul 4, 2015 at 15:39
  • 2
    Does not work on Windows 10
    – Robert
    May 4, 2020 at 12:00
5

CTRL+ALT+Home brings focus to the Remote Desktop Connection bar. The connection bar includes the minimize button.

In Windows 7, if I un-check "Display the connection bar when I use the full screen" option when making the connection, then the keys to minimize the RPD session are CTRL+ALT+Home Spacebar.

If the connection bar is set to show (which is the default) then it requires hitting Tab a couple of times to minimize the RDP session: CTRL+ALT+Home Tab Tab Spacebar.

1
  • 1
    I can do the Tab Tab Space thing when the connection bar is set to show but, for me, when I set it to not show, I still need to Tab once before Space to get past the button that launches the "connection info" screen. How did you overcome this?
    – mo.
    Nov 22, 2019 at 16:40
3

I found that you need two combinations of shorcuts. It works in Windows 7.

  1. CTRL + ALT + BREAK will minimize the maximized window to the host PC.
  2. Win + M Minimize your remote Desktop window

or in the first step you can change of window with ALT + TAB.

2
  • WIN + M doesn't work. ALT+TAB as well as you understand. It must be absolute solution, but not only for some particular configuration.
    – Kirby
    Dec 13, 2017 at 14:24
  • "Win + m" worked for me. thanks Mar 26, 2021 at 8:24
2

Bring up the host's Task Manager, then task-switch:

  • Ctrl+Alt+Delete (Windows Security)
  • T (Task Manager)
  • Alt+Tab (task-switch on host computer)
1

I do the same thing. The best solution I found in XP was virtual dimension with the virtual desktops always on top. Then I can switch among 4 remote desktops in full screen with one mouse click each. However, Virtual Dimension doesn't work quite right in Windows 7 (at least in 64 bit). It seems to work but it loses the "always on top" though the checkbox stays on, the virtual desktop switcher does not. It is so close to what we both want, but so far.

1

Ctrl+Alt+Home worked for me. I am using Windows 10 host with teamviewer to Windows 8 machine which has a terminal server running. I was able to pin the terminal server connection bar.

1
  • Is there a shortcut to "unpin" the connection bar?
    – mwfearnley
    Aug 17, 2021 at 11:30
1

You can use Dexpot and Autohotkey to set up a shortcut like Alt + Caps Lock, without Caps Lock annoying state changes (Good if you don't have Scroll Lock)

At first annoying to set up, but in the long term the most comfortable. I like to be able to quickly switch with left hand only

Dexpot

  1. Set next desktop to Alt + Scroll Lock (If like I you don't have scroll lock use windows on-screen keyboard to press "ScrLk")
  2. Set previous desktop to Alt + Scroll Lock
  3. Set screens overview to Ctrl + Scroll Lock

Now use Autohotkey to make redirections (this way Caps Lock will be prevented from changing it's state):

 GetKeyState, state, Capslock ;
    ; Alt + Caps Lock becomes Alt + Scroll Lock
    !Capslock::
        send !{ScrollLock}
    return
    ; Alt + Shift + Caps Lock becomes Alt + Shift + Scroll Lock
    !+Capslock::
        send !+{ScrollLock}
    return
    ; Ctrl + Caps Lock becomes Ctrl + Scroll Lock
    ^Capslock::
        send ^{ScrollLock}
    return

Done. Now you can use Alt + Caps Lock to switch between screens without Caps Lock changing its states.

Also if you only need 2 screens you can set dexpot to use only 2 desktops which will make alt + caps lock quick toggle for remote desktop.

0

I found this workaround using a mutli-desktop manager:

  1. Install Dexpot
  2. Configure Hotkey for "Next Desktop" to ALT+ScrollLock
  3. Configure Remote Desktop to Capture all Keys in Fullscreen Mode

Then you can switch between Fullscreen Desktops mit ALT+ScrollLock.

I set the number of Desktops to 2, as I only have 1 remote desktop.

Additionally, I have installed Clavier, which allows me use just ScrollLock to switch between desktops. (Clavier config: Add-> Write Text... -> Shortcut: ScrollLock -> OK -> Write-Text: [ALT+ScrollLock] )

0

With Vinagre (The standard Remote Desktop application on Debian and debian-based OS) there should be a menu showing up when you bring the mouse at middle the top of the screen.

You can also use the Super + Esc key combination to send the next keystroke to the host (this is mentioned in the popup when you start a fullscreen session), so you can then use Alt + Tab or Super again to switch to another app or terminate the session.

Super is the Win key (logo) on Microsoft™ keyboards.

Note: for me the top menu didn't seem to work at all; I noticed later that the tooltips would show up as I hovered around where the menu buttons should be, so the menu is there but not visible and the tooltips might be sufficient to find the right button.

Not the answer you're looking for? Browse other questions tagged or ask your own question.