Why I am always seeing this window on my system?

alt text

I have changed the disk with a new one, bigger and after a while the message shows again.

As far as I know, TM deletes old backups to store the new ones but it seems that this is not the case.

Any way to solve that?


7 Answers 7


This happened to me recently; I was pretty annoyed because I expected that if there wasn't enough space, Time Machine should just delete the oldest backup.

The problem turned out to be that the disk contained only one (large) backup, and didn't have room to store the current delta (delta = changes to files since last backup).

I realized this when I looked at the disk contents and saw that there was only one backup folder under Backups.backupdb.

I used Disk Inventory X to look at the contents of my hard disk, and identified a few large folders which didn't need to be backed up. I excluded these from the backup using "Time Machine" > "Options" > "Exclude these items from backups". The info from Disk Inventory X also led me to delete a bunch of large unused files.

After the two changes listed above, the backup proceeded successfully. I didn't have to launch the backup, it automatically retried. I presume that my changes brought the delta to a small enough size that it fit in the remaining free space on the backup disk.

UPDATE: This happened to me again recently, and just excluding folders from the backup wasn't enough, so I found another trick. Let's say you analyze your hard disk contents and realize there's a 20GB folder (let's call it UselessStuff) which was being backed up. You exclude it from the backup as described above, but that doesn't delete the previous backups of UselessStuff from the disk, and you still don't have enough space for the backup to complete. Since you don't need any backups of UselessStuff, you can enter Time Machine, right click on UselessStuff, and click "Delete all backups...". In my case, this freed up enough space to let the backup continue successfully.

  • 1
    Or the short version: Make sure your backup disk is larger than the amount of data you want to back up.
    – Daniel Beck
    Apr 24, 2011 at 16:37
  • 4
    @DanielBeck, That's not the case at all. I'm encountering this error trying to back up ~220GB to a 1.25TB disk. The issue seems to be Time Machine not deleting old backups properly. Aug 22, 2015 at 17:16

First, I wanted to point out that it's strange that the dialog shows commas in the numbers instead of decimal points. I'm not sure what's up with that. If Chris Nava's reply didn't help you, read on.

Sometimes Time Machine gets jammed up when there is a really big change in data. I can see that you have over 12GB to back up and only 2GB available. The changes have either been building up for awhile or something large was recently changed on your drive.

Is there any data on this backup drive that is not from your Time Machine backup? Is more than one Mac using the drive as a backup drive? Time Machine from one computer can't weed out data from another's backup to make room for itself.

Are you backing up a monolithic database of some kind that changes regularly? Something like Entourage's mail database can get very large and a single new mail message tags it as completely new for Time Machine. This can cause a Time Machine Backup to fill up quickly. The Photo management application Aperture does the same thing.

Also, how large is this backup drive?

  • 9
    the dialog shows commas in the numbers instead of decimal points -- welcome to the world outside of the USA?
    – Arjan
    Nov 7, 2010 at 18:08
  • 1
    Different locales use different symbols for the decimal separator. In System Preferences -> Language & Text -> Formats, try changing your region to "Belgium" to see a locale which has the commas and periods reversed. Nov 7, 2010 at 18:09
  • We here in West Podunk never pays no attention to no decimuls anyway. They's just a noosance.
    – Theo Belk
    Nov 8, 2010 at 6:03
  • Just one mac connected. I have tried with different disk sizes, from 400 Mb to 1TB. All drives show the problem, it is just a matter of how long it takes to get full. Yes, I am outside the US. So, my mac is adjusted with comas as decimals separators. I am not backing up anything large unusual. Just working on the mac creating images and stuff when I see these messages. I have seen this a dozen times in the last months. Very annoying. If the drive has 10 times the amount of space of the Mac drive, I should not be seeing this.
    – Duck
    Nov 9, 2010 at 0:37
  • You might try manually deleting the oldest backup. Open TM, and go to the oldest backup. Then go to Action menu (That's the little gear-like icon around the top of the Finder window that is visible when you start Time Machine). Select Delete backup. Maybe that will shake something loose. I'm not sure what is holding it up.
    – Theo Belk
    Nov 11, 2010 at 16:18

Hmm... I think that Time Machine creates a sparsebundle image which is particular size - when you changed your disk the image will not have been resized to match the increased capacity.

Apparently running the command (in a terminal window):

hdiutil resize -size 50g MyFile.sparsebundle

(where 50g is the size you want to resize it to, and MyFile.sparsebundle is the name of the image file).

will resize the sparsebundle image file. You will need to have "cd'ed" into the time machines directory for this to work.

Make sure your backup is backed up... if you know what I mean.

Of course, the above could be nothing to do with your problem - It's just a thought!


Open preferences and make sure it says "The oldest backups are deleted when your disk becomes full."

  • this is always turned on... since the first day I started using TM, but even so I see these messages from times to times. Very annoying!
    – Duck
    Nov 9, 2010 at 0:38
  • In that case the answer from @Theo Belk is more likely correct.
    – Chris Nava
    Nov 9, 2010 at 19:01
  • This option is no longer available in OSX.
    – altabq
    Mar 12, 2019 at 14:33

In my case, "another computer" had a backup on my backup disk.

Using Finder, look inside /Volumes/<your backup disk>/Backups.backupdb/<your computer's name>/Latest.

It's possible that you might find an entry you don't expect in addition to <your computer name>.

Or, like in my case, you look there and find nothing interesting, but fail to look in ../Latest right away which would have made you realize that your old computer (same hardware, pre-Lion clean-install) had the same name as the new one but a custom hard drive name. The backup from the old hard drive name was never re-used and never deleted.

I made sure I didn't still need anything in that backup, then deleted it. Backups have proceeded normally from there.

Good luck to all!


As stated within Time Machine's preferences, "The oldest backups are deleted when your disk becomes full." This process works great so long as you don't have a large amount of data added to your source disk at one time.

I had the same issue you've described above after downloading a really big file and doing an OS X upgrade. With a change that big, Time Machine didn't have the space necessary to purge the old data and make space for the new.

Solution: Navigate to your backup disk using Finder. Manually delete the oldest backup folders (i.e. perform the task Time Machine typically is able to do automatically) then, tell Time Machine to "Back Up Now". You'll be back on track and good to go until the next time you pull in a large amount of data to your source disk while Time Machine is running on a "full" backup disk.

  • Do you have any reason to believe that's a safe operation? Time machine saves "deltas" -- just the bytes that have changed between backups -- so entries are linked together through time. Manually deleting one delta could potentially corrupt all future backups.
    – emcmanus
    Apr 20, 2012 at 2:07
  • So far so good. It's been over a month and I haven't had any issues.
    – John Erck
    Apr 21, 2012 at 4:43
  • As far as I know every dated folder inside the Time Machine backup package/folder contains complete modified files for that backup session, and hard links to older, unmodified files. So there are no partial files or deltas in the backup. If someone can verify this, great.
    – Niko Nyman
    Sep 10, 2012 at 9:54

Remember to exclude other disks as well where necessary.

Example: My internal 1TB fusion drive recently developed bad sectors, with major beach balling, so I switched to using a 2TB external SSD over USB 3.0 as my startup disk (I highly recommend Superduper, by the way).

Time Machine, backing up to a 1TB spinning external HDD, promptly run out of room, despite my startup disk using rather less than 1TB right now. So I wiped the Time Machine backup and tried to reset it - it still kept failing with an estimated size of 1.6TB. Why could that be?

Turns out it was trying to backup both the original internal "Macintosh HD" as well as the new SSD drive, so you need to exclude the entire old drive for a full backup to fit within the available space.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .