4

For some reason, Gadgets in my Windows 7 OS stopped displaying properly. Did a little research on internet and found that UAC may be the culprit. However, despite putting UAC on level 2, they still don't appear properly.

I am able to choose and add Gadgets on the desktop, but they won't display properly.

--

My Problem is exactly depicted in this screenshot that I found on the Internet:

alt text

4
  • "won't display properly " - explain that with a bit more detail?
    – Mussnoon
    Nov 10 '10 at 14:41
  • I mean, if I add clock to the desktop, All I can see is a black background with a green vertical line. Even the other gadgets aren't getting displayed properly. I can show you a screenshot, but I am not sure how to add it here.
    – Ctroy
    Nov 10 '10 at 14:51
  • And FYI, I created a new account (for testing) and gadgets appear fine there. But not in the account I use regularly.
    – Ctroy
    Nov 10 '10 at 14:52
  • Have you turned UAC off? I've seen a lot of posts from people who have had problems after turning UAC off
    – Joe Taylor
    Nov 10 '10 at 17:09
2

I suggest you disable "Windows Gadgets Platform", restart your machine, re-enable it and check if the problem persists.

To do that, go to the Control Panel, click the Programs heading, and choose Turn Windows features on or off. Find the Windows Gadget Platform option and remove the check mark from the box to its left, then click the “OK” button.

alt text

1
  • Did both of them earlier, but didn't help :(
    – Ctroy
    Nov 10 '10 at 14:58
1

Try Re-registering vbscript.dll file.

Open an elevated Command Prompt window. by clicking on Start -> All Programs > Accessories. Right-click Command Prompt, and then click Run as Administrator.

Type the following command and press Enter

regsvr32.exe vbscript.dll

You should see the following message after running the command:

DllRegisterServer in vbscript.dll succeeded.

Close any gadgets and open them again. If that does not help, restart Windows and check.

3
  • Tried it. Didn't work.
    – Ctroy
    Nov 10 '10 at 15:14
  • Did registering the dll outright fail, or did it register successfully but not solve the problem?
    – nhinkle
    Nov 11 '10 at 6:18
  • That fixed this issue for me. Issue caused (I am pretty sure) by installing Visual Studio 2012 Pro ...
    – liamf
    May 1 '13 at 17:36
0

Have you tried resetting the windows sidebar folder in your application data folder? Try killing the sidebar process (from the task manager), then go to %userprofile%\AppData\Local\Microsoft\Windows Sidebar and remove all of the files (or copy them elsewhere to keep a backup). Then, open up the gadgets window from the desktop and try adding gadgets. It should behave the same as if you were adding gadgets to a new account.

0

You should delete 1 extra (parasite) zone from

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\

with pseudo-graphic number, you'll see it before zone number 0. It seems this is a bug of Adobe flash player update, though I am not sure.

The pseudo-graphic number is before zone number 0 looks like a miniature upper case "L".

Delete that registry entry and all is well.

(paraphrasing a proposed answer from Sledge / Pete, which got wiped unfortunately)

Not the answer you're looking for? Browse other questions tagged or ask your own question.