My F3 key died. I do not suspect HW problem, since it happened while I installed an alternative Search program (what are the odds that F3 would die, and just at that time?).

I uninstalled the program and restarted, F3 is still dead.

Help with fixing the problem by hand is more than welcome! Since I took a restore point just before installing (glad I'm cautious) I could solve it that way, but I'd like to learn to do it the hard way. I suppose it involves digging in the registry.

When testing the keyboard input with help of passmark keyboard test ( http://www.passmark.com/products/keytest.htm ), it turns out that F3 sends the wrong key code:

                     F1    F2    F3    F4
Windows Key code    112   113   177   115
BIOS Key code        59    60     0    62

Now I need to find out how the key code got remapped.

  • 2
    just to rule out a HW fault in the keyboard, does the issue change with a different keyboard? – Xantec Nov 12 '10 at 13:14
  • Good point. My other keyboard does not react on F3 either (testing that in windows explorer). – Gauthier Nov 12 '10 at 16:02

Problem fixed, it was indeed caused by the keyboard's firmware setting.

My keyboard (Kinesis contoured advantage) has several modes, one of which is "media player". In this mode, F3 is mapped to "previous track". All other keys worked as expected (checked with passmark), which makes me think something went wrong in the keyboard's firmware. If the media mode had worked, other keys should also have changed behaviour.

Checking with the other keyboard still showed the F3 problem, but the "faulty" keyboard was still plugged in while testing. I guess that was disturbing.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.