6

I'm trying to:

  • Take a system image of my current WIndows 7 x64 setup, which is using IDE-mode storage
  • Enable RAID in the BIOS
  • Install two new drives and set up a RAID mirror
  • Restore my system image onto the new mirrored C: drive

The problem is - my existing Windows 7 install won't boot if the storage controller is set to RAID or AHCI mode (instead of IDE) in the BIOS.

The Windows 7 system recovery process works fine - will quite happily restore my old C: drive image onto the new mirrored C: drive - but then this won't boot, either.

I'm guessing that I need to install the Intel Matrix Storage Manager RAID drivers - but if I try to do this with the BIOS configured to use IDE, the installer reports:

"This computer does not meet the minimum requirements for installing the software."

So - I can't boot with RAID enabled in order to install the drivers, and I can't install the drivers first in order to boot with RAID enabled.

Any bright ideas? Really rather not reinstall if I can help it.

  • can you boot it into safe mode when running on the raid? – Xantec Nov 12 '10 at 13:29
  • Nope. Will boot into recovery mode off a Windows install DVD but I don't know how you slipstream drivers into a separate Windows install having done so. – Dylan Beattie Nov 12 '10 at 13:48
8

This was by far the simplest solution I could find. The others involved reinstalling windows, downloading sketchy software or large registry hacks.

1) With RAID disabled, boot into Windows and start Regedit.exe

2) Navigate to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\iaStorV

3) In the right-hand column, you should see a value named Start. Double-click this entry and change the data from 1 to 0.

4) Reboot with RAID enabled – Windows should load just fine. Now install the Intel Matrix Storage Manager as you usually would. This time around, it should detect your hardware and install without any issues.

  • 1
    You, sir, are a steely-eyed missile man. That worked like a dream. Thank you. – Dylan Beattie Nov 22 '10 at 11:07
  • Good solution that gets a +1, so did 'Steely eyed Missile man' made me laugh – Joe Taylor Nov 23 '10 at 11:58
  • Oh no, but the current value is 3! – Alain Aug 22 '12 at 23:02
  • I had a "3" as well, but changed it to 0 anyway and this still worked. Thanks for this answer! – andrew Oct 26 '12 at 19:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.