I'm using Ubuntu 10.04 with a HP Scanjet 4400c. When I'm trying to scan a white sheet of paper with black and blue text for example, it look like this:

What could be the problem? I've used different Ubuntu applications (Skanlite ...), all with the same result. According to http://www.sane-project.org/sane-mfgs.html the scanner should be supported.

In Windows XP (same computer), the scanner works as expected.

Update dec 04 I just updated to Ubuntu 10.10 in the hope that new drivers would be installed. I still get the same result.



I had to solve this problem with another machine, so I found the following way to do it.

It's kind of "more official" than the one below.

Here are the instructions, they worked for me:


It's needed to add a PPA (an external repository) to the packages manager and to install a couple of things.

It was pretty simple and worked.

I don't remember the exact procedure, I did it some time ago, so I won't post it, but the instructions are very clear and they work.

Previous answer:

I had the same issue with a HP Scanjet G2410.

My solution may work for you:

Download this file: http://rapidshare.com/#!download|209l33|117078532|HP_Scanjet_2400.zip|6361 This is a driver for the HP Scanjet 2400, but it worked for my scanner, it's even more possible that it works for yours.

(You may need to install sane first) Unzip it and follow the instructions in the README_hp2400.txt file.

Those instructions worked perfectly for me.

  • I got that file link from a comment in this blog: Link in comments (I had to delete this link to post the new one in the update)

The original link is broken, and almost all blogs and forums where I looked for info linked that broken file, so this rapidshare file was the only one that I could download.

The instructions in that blog (and the other blogs) are almost the same, and are almost the same than those in the readme file. I installed sane and followed the readme file instructions, and that is what worked for me.

  • You do know that Rapidshare files won't stay there forever, right? – slhck Sep 19 '11 at 7:56
  • Thank you very much for your answer. Unfortunately, I replaced the scanner in the meantime so I have no way of verifying your solution. Hopefully it will help someone else solving the same problem. Note slhck's comment though about rapidshare! – pgruetter Oct 5 '11 at 6:22
  • * link of the blog's comment: racoon97.blogspot.com/2009/04/… (I had to delete it from the post to add the new link in the update) – Sebastián Ramírez Nov 27 '11 at 5:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.