I have a desktop computer with a wireless card, running Windows XP SP3. For a little while, I had a remote network connection set up for my job, but I didn't need the remote connection so I deleted it. Now, I am unable to connect to the internet at all from that computer through my wireless router.

I can connect through my router using my laptop, and I can connect through my neighbor's router using my desktop, but for some reason I can't connect through my own router using my desktop.

I see the "Wireless Network Connection 5" icon in my system tray, but it tells me it is not connected. When I click on the icon, I see a list of wireless networks, including my own, which is set up to automatically connect, although it doesn't. When I try to connect to my network on my own (by clicking on it, then clicking "Connect"), it asks me for my network password like it usually does. I see a box come up saying "Waiting for network to be ready..." and it hangs there. On the list of wireless networks, my network says "Acquiring network address" but it doesn't actually connect.

How can I fix this? I tried rebooting my computer, repairing my connection, and restarting my router, and I am still having this problem.

  • I've read through the other answers and comments and I can't see any indication that you've tried to delete your wireless device from Device Manager in Windows, nor that you've deleted all known wireless connections on the device and started over. Have you? This may be a Windows problem and not a router problem. – user3463 Nov 14 '10 at 4:40
  • I don't think it is a router problem. It seems like I can connect to my router using any computer other than my desktop. I will try your suggestion when I get a chance. – Elias Zamaria Nov 15 '10 at 7:54
  • Randolph Potter, When you mention deleting the device and deleting all known wireless connections, what do you mean? – Elias Zamaria Nov 16 '10 at 2:12
  • Have you tried to connect to your router with another computer (or smartphone)?
  • Check your protocols on the card
    » Network conections - right click on the wireless card - properties
    » You should have only about 4 to 5 items (Microsoft Client and TCP/IP the most important)
    » If you have Novell, or NetBeui there's the problem

  • Another thing I usually do is to start from scratch. Access your router and remove the encryption. Try to conect without encription. Then if sucessfull, increase to WEP. Then WPA.

| improve this answer | |
  • Yes. I can connect to the router fine using my laptop. I didn't mention this in the question but my brother can connect to the router fine using his laptop. I don't know why the protocols on the card would be a problem. It worked fine before. I didn't change anything. It still connects fine to my neighbor's router. – Elias Zamaria Nov 14 '10 at 1:39
  • I looked at the protocols. I see "Client for Microsoft Networks", "Virtual Machine Network Services", "File and Printer Sharing for Microsoft Networks", "QoS Packet Scheduler", and "Internet Protocol (TCP/IP)". I don't see Novell or NetBeui. – Elias Zamaria Nov 14 '10 at 2:25
  • OK, if your brother connects fine, it has to be your computer. So, have you tried to delete your Wireless Conection? Right click wireless card, properties, wireless networks, in prefered networks, delete yours. Close all windows and try to conect again. – Marco Clérigo - GRIFIN.pt Nov 15 '10 at 0:04
  • I went into my router settings, disabled the wireless network security, and tried to connect to it from my desktop. It worked. I tried setting the security back to "WPA-PSK and WPA2-PSK" and tried to connect. Now it doesn't work. – Elias Zamaria Nov 16 '10 at 2:21
  • 1
    I experimented a little and found that it works find if I set the security to "WEP" or "WPA-PSK" but not "WPA-PSK and WPA2-PSK" and not "WPA2-PSK". I decided to set it to "WPA-PSK". Is that a good choice or is there some sort of risk involved with it? – Elias Zamaria Nov 16 '10 at 2:27

If nothing else works, try this as well: Start, Run, write: cmd. Then copy the following, right click on the command window and paste:

netsh int ip reset resetlog.txt
netsh winsock reset all
netsh interface reset all
netsh interface ip reset resetlog.txt
netsh interface ip delete arpcache
netsh firewall reset
netsh nap reset configuration
netsh routing reset
| improve this answer | |
  • I tried all those commands and it doesn't work. I tried restarting and it still doesn't work. – Elias Zamaria Nov 16 '10 at 2:11

I actually had this EXACT same problem a week or two ago! When you say you "reset" your router, do you mean you unplugged it or pushed down the little button on the back with a pencil until it reset? I just kept resetting the router the router via the pencil method until it worked. My wireless network isn't currently encrypted/secured, if yours isn't either then someone might have pushed the "synchronize security" button, I think that's what happened to me. My wireless card is USB, so I tried taking it out and putting it back in. I am not 100% which of those actually fixed it, but keep trying a combination of those things until it works, that's what I did. Well, best of luck...sorry I can't be of any more help.

| improve this answer | |
  • I pushed the button on the back. I also tried restarting it from within the built-in utility ( My network is secured via WPA. My wireless card is internal, so it would be a little cumbersome to take it out and put it back in. But I doubt that anything is wrong with the wireless card, because it can connect just fine to my neighbor's unsecured wireless network. – Elias Zamaria Nov 13 '10 at 21:13
  • Have you tried resetting the modem too? I believe this will put you back at square 1 and you will have to reconfigure everything (e.g. your wireless security settings) but it might allow you to connect to your network? – Mr_CryptoPrime Nov 13 '10 at 21:22

I just thought of something else. It may be that one of your other computers is automatically reconfiguring the router settings. To try and fix this do the following:

1) Turn off all computers within the vicinity of your network. 2) Reset the router by holding in the button for 15secs until the lights indicate that it has fully reset. 3) Unplug the router and wait 30sec to ensure all buffer data is cleared, then plug the power cord back into the router. 4) Turn the computer that is experiencing difficulties back on and try to reconnect.

If this doesn't work, then try totally resetting the modem. Note that this should erase all settings and will return it to the out-of-box state. If you have tried all other venues, then I would then go for this option. Best of luck!

| improve this answer | |
  • What makes you think that one of my other computers is reconfiguring the router? It seems like I can connect to the router fine using any computer other than my desktop, and I can connect to any router other than mine from my desktop. – Elias Zamaria Nov 14 '10 at 1:40
  • I tried the procedure you suggested and it didn't fix anything. The router forgot my password and other settings. I changed them back and it is acting like it did before. I can connect to the router using my laptop or my brother's laptop, but not from my desktop. – Elias Zamaria Nov 14 '10 at 2:23
  • What do you mean by "totally resetting the modem"? Is that any different from resetting the router like you described? – Elias Zamaria Nov 14 '10 at 2:30
  • Yes, the modem is what you plug the phone line into, then that connects to your router...Well, it looks like someone else solved your problem! :) – Mr_CryptoPrime Nov 23 '10 at 20:18

Find the most recent drivers for your wifi card and just update it'll work, I searched a long time and solution was so simple. It isn't XP but the driver linked to XP for your wireless card or USB stick.

A to old drive doesn't let you connect with a WPA2 identification protocol, you get the go but no return is correctly sent back to the computer as the drivers aren't able to translate correctly the answer that has been sent by the router.

| improve this answer | |

I had the same problem , I tried everything the others users said, finally my problem was related with my router, this had setup to use WPS , and for that reason every time when I tried to connect my laptop to the router, this did not ask for the password, after I disabled the WPS in my router my laptop was working fine.

| improve this answer | |

I had the same trouble, and I noticed in my router settings that the router was configured to support both WPA-PSK and WPA2-PSK.

So on the XP computer, I opened Network Connections and then the Properties of the wireless connection. Then, under the Wireless Networks tab, I saw it stored the preferred network to which it was failing to connect. So I clicked on that network and clicked properties, and saw it was trying to use WPA2-PSK authentication. I changed that drop-down to WPA-PSK, clicked OK then OK again to save it, and immediately it started acquiring an IP address and finally connected.

| improve this answer | |

Changing the WPA2-PSK to WPA-PSK in the properties worked for me too. Funnily enough, I have a 2nd wifi hotspot whic is able to connect on that computer with WPA2-PSK setting. I guess this'll just have to go down as another quirk of Windows.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.