i have a windows xp machine and i am trying to delete a directory with some old source code that was once hooked up to subversion but the repository is no longer there.

when i try to delete the directory i get this error:

alt text

i see that the directory is read only but when i try to remove the read only flag, it pops up this screen:

alt text

but then fails with the following error:

alt text

i have tried using unlocker and a few other tools but nothing will allow me to delete this directory.

i do have admin rights on the machine. Is there any recommendation for something that can brute force delete a directory even given the above issues. I am not sure if this is subversion not allowing the deletion or its something in windows xp directly.


It seems now that i can delete individual files in a directory but can't delete any directories or any bulk directory sub directory delete.

as mentioned, unlocker does pop up but says that no other process has no handle locking the files

alt text

also, i disabled Simple file sharing and took ownership of the folders (i was not originally) and then tried the steps above but still getting the same access denied errors.

  • Try and kill TSVNCache.exe in task manager, then delete the dir. Assuming you have rebooted, etc...? – Aaron McIver Nov 15 '10 at 14:19
  • @Aaron - even killing TSNVCache.exe still has the issue. as mentioned, i have unlocker and that doesn't see anyone locking the file – leora Nov 15 '10 at 14:29

You could try taking ownership of the folder following these steps. It appears it may have something to do with permissions/security since Unlocker is not recognizing any locks on the files/folders.

|improve this answer|||||
  • @Aaron - even after taking ownership of the folder, i still and getting the same errors after trying to delete the folder / files – leora Nov 15 '10 at 15:01
  • @ooo You took ownership then gave yourself privs? – Aaron McIver Nov 15 '10 at 15:12
  • @Aaron - yes. it seems the issue is trying to delete the .svn folders and the "entries" svn file. Still getting access denied on these – leora Nov 15 '10 at 15:58
  • @ooo Ok, so only on svn dirs...this may sound strange, but have you uninstalled your SVN client, rebooted and then attempt to delete? – Aaron McIver Nov 15 '10 at 16:04
  • @Aaron - i completely uninstalled tortoise and then rebooted and still having issues deleting the entries and the .svn directories – leora Nov 15 '10 at 17:31

This likely means that the file is locked by some other process.

One way to find this out is to use Process Explorer, and use the Find Handle Or DLL function to find out which process has a lock on the entries file. I'm sure there are other utilities that will perform the same functionality.

Once you know what process has locked the file, close that process (or cause it to relinquish the lock) and try again.

As a total guess, I would suggest that if you're using Tortoise SVN, the TSNVCache.exe process is the one locking the file.

|improve this answer|||||
  • He mentioned the use of Unlocker, which looks for locks and unlocks them as needed. – Aaron McIver Nov 15 '10 at 14:23
  • @Andrzej Doyle - even killing TSNVCache.exe still has the issue. as mentioned, i have unlocker and that doesn't see anyone locking the file – leora Nov 15 '10 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.