5

I have installed Windows 7 on MacBook Pro using BootCamp. Usually when turning my Bluetooth headset on and trying to pair it with Mac for the first time, Windows fails to install the drivers and opens a solution in Action Center, which suggests to download the driver from the Broadcom webpage. This used to work for me before, drivers were installed and everything worked well. However now, when I start the driver installer, it would get stuck at "Detecting Bluetooth Device" stage. There is also a warning with text, which says "Please plug in or turn on your Bluetooth device":

Broadcom Driver Installer

I have tried turning my headset on/off, bringing it into pairing mode, installing/uninstalling device to/from the Bluetooth Devices. None of these worked. Any ideas?

3

I've found that installing the Acer Broadcom Bluetooth driver on the following web page works for a late 2010 15" MacBook Pro running Windows 7 Home Premium 64-bit under BootCamp:

http://www.downloadatoz.com/driver/articles/free-download-acer-aspire-as5740-laptop-driver.html

Before installing the driver the laptop would detect the Bluetooth device (Creative D200 speakers) but not be able to pair due to lack of a driver, which it then searched for but could not download. After installation the speakers work fine. They use the A2DP high quality BlueTooth audio codec.

  • 1
    After reinstalling Windows I have faced same problem. You solution helped. Thanks. – Sergiy Belozorov Jul 18 '11 at 21:44
  • Just re-installed Windows yesterday. Apparently Broadcom have updated their drivers and they are much more stable now. Make sure that you have the newest version. – Sergiy Belozorov Nov 16 '12 at 7:36
2

Apparently what it tries to find is the bluetooth receiver itself, not the device that connect to it (e.g. headset, mouse etc.). I have no idea why it didn't work with built-in device that is somewhere inside my laptop, but it did with another external bluetooth usb thumb. Once I have plugged it in, the installer has recognized it and installed drivers. Apparently same drivers worked for my built-in bluetooth, so i just unplugged usb thumb and since then it works for me. Hope this will be useful for someone.

1

As @bagasas notes, just install the Broadcom drivers and everything seems to fix itself: driver download link

1

This was driving me nuts. I put in a larger SSD today going from a 120GB to a 240GB and blew away my Windows partition to make the process easier to expand OS X, etc. After installing Windows again, the only thing in Device Manager that wouldn't load was the Bluetooth USB Host Controller. Tried every package in Bootcamp for version 4.0.4033 and 5.0.5033 and no luck.

Finally I came across this site: Solution: How to get Bluetooth to work in Parallels 7.

  1. Basically, right-click the device in Device Manager, go to Properties, select Details tab, choose Hardware Ids from Property drop down. Copy the shortest value. (For illustration, he reports that his was USB\VID_05AC&PID_8218.)

  2. Find your bootcamp drivers and under bootcamp/drivers/apple/x64 copy AppleBluetoothInstaller64 to a folder on your desktop and unzip it. I use WinRAR to extract to the same folder.

  3. Find the files that got extracted/unzipped and, using Notepad, edit the file called AppleBT64.inf.

  4. Look for the following lines:

    ; for Windows 7 only
    [Apple.NTamd64.6.1]
    ; No action
    ; OS will load in-box driver.
    

    Get rid of the last two lines, i.e., the following:

    ; No action
    ; OS will load in-box driver.
    

    And add this line (paste your value you got earlier in place of USB\VID_05ac&PID_8218):

    Apple Built-in Bluetooth=AppleBt, USB\VID_05ac&PID_8218
    

    So in the end it should look like the following:

    ; for Windows 7 only
    [Apple.NTamd64.6.1]
    Apple Built-in Bluetooth=AppleBt, USB\VID_05ac&PID_8218
    
  5. Save the changes.

  6. Select Update the driver for the Bluetooth device in Device Manager and point it to the folder with the extracted/unzipped files and it should install the Bluetooth drivers then.

Updated: Just found this link as well that does the same thing: http://kb.parallels.com/en/113274

0

Easiest way on Windows 10 this worked for Late Mac 2013 with i7 intel (just figured it out)

  1. Uninstall the current driver from Properties tab
  2. Go back into properties tab and it should give you the option to install a driver because there is none installed.
  3. add driver from list of available drivers already on windows when it prompts you to browse (should be the options underneath the browse one telling you to install from already available windows drivers)
  4. on the list shown with all the manufacturers choose Broadcom then under the sub list that appears chose the ANYCOM USB-200/250 Blue tooth Adapter.

Woila! itll detect everything on your MacBook and you should be able to connect your mouse to the computer at that point it takes about a minute or two to start seeing the mouse work and I'm assuming any hardware you try to connect will be similar. Not sure why people are making it difficult using editors etc this worked flawlessly.

Good Luck!

-1

This link worked for my W7 running on a macbook pro 2010 http://support.lenovo.com/be/fr/downloads/ds003619

  • Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change. – DavidPostill Jan 21 '17 at 18:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.