I've added Russian and the Russian typewriter keyboard layout in the Windows XP language settings and was able to use Russian letters in Word without a problem.

But when I tried to switch back to either my German or my US language/keyboard settings, the keyboard layout was the regular Latin character layout on the left side of the keyboard (seriously!), and it had mostly numbers and German Umlaute (ä, ü etc.) on the right hand side of the keyboard. Each number/letter occurred several times, whereas most of the letters that are usually on the right side of the keyboard are not there at all.

I tried switching back to Russian, but even that won't work anymore.

Obviously, this makes it impossible for me to use that laptop computer on which this happened at all, as the windows setting apply to most everything, including Firefox (I'm not writing this message on that laptop, of course!). Does anyone have an idea what I could do? I've already tried removing all language options but one, but that doesn't seem to help.

Thanks for all help you may be able to provide ...!

(I'm also a former Mac user who can't really afford their expensive machines anymore, but I should add that nothing like this ever occurred on my Mac ...)

  • If you type the first row of the keyboard, does it go QWERTY or QWERTZ? If the latter, it still thinks it's in German. That might help you figure it out. – user3463 Nov 19 '10 at 16:46

I've got the answer ... I seem to have inadvertently hit the numlock key on my laptop's keyboard.

Think I've seen this answer as the solution to a similar problem, but first did not realize that this simple solution might apply to my problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.