I have a strange directory in my disk because of which my system update to 10.6.5 is failing

degreethem-lm:RemoteManagement jithine$ pwd /System/Library/CoreServices/RemoteManagement
degreethem-lm:RemoteManagement jithine$ ls -l
total 0
drwxr-xr-x 3 root wheel 102 May 22 2009 ARDAgent.app/
d--------- 3 root wheel 102 May 22 2009 AppleVNCServer.bundle/

I tried going to no matter what I do i get permission denied when trying to change the permission to 755 using chmod. I also tried going to single user mode and change the permission but did not work out.

up vote 0 down vote accepted

Try repairing the permissions (run Disk Utility, select your boot volume in the sidebar, then the First Aid tab, then click the Repair Disk Permissions button). This'll reset the permissions of the files installed with the OS back to what they were originally, so it should fix this file and any others that have gotten messed up.

  • That failed for the aove mentioned directory. Its says "Error 1: Operation not permitted" – Jithin Nov 20 '10 at 3:54
  • 1
    Is the directory locked or something? Try ls -lO to see if it has any file flags set. – Gordon Davisson Nov 20 '10 at 5:44
  • That was the issue the directory had schg flag set. removing it made it like a normal one under my control ;) Thanks Gordon. – Jithin Nov 20 '10 at 17:48

You sure you're trying to chmod it as root? I feel like I've encountered that before... Make sure you've done a disk repair in addition, in case something is messed up that isn't letting you change the file permissions. If all of that still fails you may just have to delete it and restore that file from backup or an equivalent system.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.