Randomly starting this morning, my mouse cursor has stopped working properly. It seems to be that whenever I switch to a new window, the mouse cursor changes to what it is supposed to be at that instant, but then it doesn't change to anything else.

For example, I'm running Chrome at the moment. If Chrome is not the active window, and then I click on an unimportant part of the page, then my cursor will stay the standard black arrow, no matter where I move my mouse. If I hover over (or click on) text, it doesn't change to the I-bar, and if I hover over a link, it doesn't change to the little hand icon. But if I click on a different window, and then I click on a link in a Chrome window to bring Chrome to the front, then my cursor is stuck as a hand icon regardless of what I click on thereafter. The only way to get the cursor to change is to click on an inactive window, and then the cursor changes to whatever it is supposed to be, where I clicked.

Also, other mouseover events aren't being registered. When I hover over a link in Chrome, I don't get the "link preview" at the bottom of the screen. Nor do Flash games respond to mouseover events as they used to.

Also, the dock at the bottom of the screen used to "track" my mouse activity, growing whichever icon my cursor was currently over. Now, it grows the first icon I touch, but as I move my cursor back and forth over the icons, it doesn't animate at all. Only the first icon stays large. I can still click on the small icons to activate other applications.

If I single click a menu at the top of the screen, only the menu I clicked stays open, even when I mouse over other menus. So I can click the Apple icon at the very top-left, but when I mouse over Chrome right next to the Apple icon, the Chrome menu does not open. Moreover, as I mouse over the individual items in the Apple menu, the individual items do not get highlighted.

I have rebooted once and this behavior has continued.

Maybe I haven't been searching the right terms, but I haven't been able to find anything relevant on Google.

I'm running OSX 10.6.5.

I'm completely at a loss -- I still don't know how to do many things in OSX. Any help will be very much appreciated.

  • I had the same problem with a Razor DeathAdder 2013, running on OSX 10.8.4 Unplugging and replugging in the USB cable did the trick. I hope I don't have to do this too often!
    – user248497
    Aug 26 '13 at 4:26
  • @user248497 I have the same exact problem with the death adder 2013. I'm running Mavericks. Unplugging and replugging only works if you don't change apps. If you do, the cursor doesn't change as before. Have you had any luck? Aug 7 '14 at 15:49
  • I just had this problem (Macbook trackpad), rebooting solved the issue (at least so far)
    – touko
    Apr 27 '17 at 9:18

It looks like I posted a few minutes too soon. By searching for osx mouse troubleshooting, I found this link on Daniweb on the first page of results, where JustOneThing said:

What fixed this problem (for me) was merely disconnecting the reciever of the mouse (a Logitech MX Laser <some-number>) and connecting it again. Oddly enough it wasn't sufficient to disconnect and reconnect the USB hub the reciever was connected to (as I initially tried out of pure laziness). I hope this is of assistance to someone :-)

Indeed I am using a Logitech MX mouse, and simply unplugging the mouse from USB and reconnecting it fixed the issue. That is not at all the kind of fix I would have expected.

The main thing I searched before, which did not give relevant results, was primarily 'osx cursor not changing'.

  • I too have the same problem (with the same fix) about once a week... MX laser mouse on OS X. Only difference I can see is that, I can just unplug the USB hub and plug it back in to fix it (don't need to unplug my receiver), but I wonder if your HUB removes power from the receiver when you unplug it (is it powered?) and if that's the difference... Dec 1 '10 at 6:04
  • So I just started having this same problem on OSX 10.8.2 and it was a Logitech G5 mouse that was the culprit. When it's plugged in I have issues.
    – akraut
    Nov 21 '12 at 23:55
  • 1
    I have a similar issue with a Rat5 mouse. Strangely enough when I use my Logitech G5 it works fine!
    – Sheff
    Sep 30 '14 at 8:41
  • 2
    This isn't a fix, it will just happen again.
    – Jleagle
    Jan 1 '16 at 21:41
  • 2
    Encountered same issue (and solution worked!) on OS X 10.11.6 El Capitan. Mouse is a Logitech M100. I also have USB Overdrive installed.
    – fgysin
    Aug 10 '16 at 6:19

Having similar issues with Logitech MX Master: cursor stopped changing when hovering over links, etc. Re-running the Logitech Options control program from System Preferences seemed to help.

Not the answer you're looking for? Browse other questions tagged or ask your own question.