I am having issues being able to login to Windows XP Pro after installing Ubuntu:

Windows XP Pro was installed first (has been installed for quite a while now, not a fresh install - patched to service pack 3 and latest updates) and resides on the C: all by itself with one partition.

I just installed Ubuntu 10.10 on a separate hard drive, d:, with standard partitions created during the install.

When the computer boots I am brought to grub (version 1.98+20100804-5Ubuntu3) to pick which OS to boot

The issue I am having is after picking Windows XP the keyboard and mouse do not work upon getting to the login screen; thus, I can't use Windows XP anymore.

This is an older dell, a dimension 8250. A lot of the reading I had been finding was making sure the BIOS options had USB support on boot, which it always had; just to point that out. The keyboard works to enter the BIOS screens (using default F2 for setup, F12 for boot menu) as well as to select the OS in grub. Not sure about the mouse only because there's no GUI to see the mouse until the windows xp login screen.

The keyboard and mouse work just fine, of course, when booting into Ubuntu and worked fine prior to the Ubuntu install (for windows), but for reference they are a logitech g15 keyboard and logitech g5 mouse

some info:

josh@joshLinuxBox:~$ sudo fdisk -l [sudo] password for josh:

Disk /dev/sda: 120.0 GB, 120034123776 bytes 255 heads, 63 sectors/track, 14593 cylinders Units = cylinders of 16065 * 512 = 8225280 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disk identifier: 0x9dc96e9e

Device Boot Start End Blocks Id System /dev/sda1 *
1 14588 117178078+ 7 HPFS/NTFS

Disk /dev/sdb: 40.0 GB, 40020664320 bytes 255 heads, 63 sectors/track, 4865 cylinders Units = cylinders of 16065 * 512 = 8225280 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disk identifier: 0x000448dc

Device Boot Start End Blocks Id System /dev/sdb1
1 4675 37545984 83 Linux /dev/sdb2 4675 4866 1533953 5 Extended /dev/sdb5
4675 4866 1533952 82 Linux swap / Solaris

Any thoughts?

2 Answers 2


i had some weirdness from windows dealing with usb devices...try switching ports the devices are plugged into....shouldn't make a difference, but sometimes it does. you can always switch it back. after some recent windows patches one of my friends even had problems with a usb hd not even getting recognized booting only windows.

  • I tried moving them once when I got to the XP log in screen to no avail. However, I'll attempt it again and get back.. might be something this "easy" since last time I logged in the keyboard and mouse were connected through a belkin kvm switch - though I have in the past changed this and never had this issue.
    – Josh
    Nov 22, 2010 at 17:07
  • was able to work on this this past weekend.. and after a few reboots and whatnot it seemed to work.
    – Josh
    Nov 29, 2010 at 15:58
  • good deal...not sure on the WHY, i have just seen this symptom before Nov 29, 2010 at 16:29

enable usb support for keyboard and mouse in Bios Also try to enable usb legacy support if any

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.