I'm trying to help a friend with their laptop. It's suddenly stopped recognizing the DVD drive.

As it's patching was out of date I've applied Vista SP2 and anything else that was overdue. I've also tried pulling down drivers from the Toshiba site as well as the pretty popular MS reg fix to remove upper & lower filters.

I've tried a different drive in the bay which didn't work either.

The drive does not show up in Device Manager at all - not even as an unrecognized device.

Is there anything else I can try before I hand it back & write it off as a mobo fault?


Toshiba Equium A210-1C4 Drive is labelled as Toshiba Samsung TS-L632 I've installed the drivers listed on the Tosh site.



What is the Toshiba's exact model?
What make is the DVD drive?
Do you need special drivers for it?
Is your chipset driver up-to-date (normally found in Toshiba Support site)?

  • Updated above - i've done the bios but not the chipset. Will give that a try now. – Chris W Nov 23 '10 at 10:58

Have a good look in the slot to make sure there is nothing in there to prevent a good contact with the socket. Some CD/DVD drives have a small bracket on the back to make sure they fit snug, I have had a screw fall off one of these and cause a problem with the fit, even though it appeared to be flush and the drive had power.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.