11

The Microsoft Terminal Services Client (Also known as "Remote Desktop" or RDP) is an awesome remote access tool that I use all the time. It has but one major annoyance -- there's a bar at the top of any full screen window which is used to control the remote session itself. I understand the need for such a bar (to do things like minimize the mstsc session itself), but it would be better if instead of auto-hide, it would simply only show when I press a certain keyboard shortcut or something like that.

I'm open to looking at third party clients if they would be able to make that frustrating connection bar go away :)

(Specifically, it screws things up when I'm using Google Chrome inside an RDP session, because putting my pointer where the tabs are causes the connection bar to appear and block me, and it also causes problems if I use the Areo Snap feature to maximize the current window in Windows 7 guests)

4
  • if you edit the connection and go to the Display tab and uncheck "Display the connection bar when in full screen mode" does that fix the problem?
    – Xantec
    Nov 23, 2010 at 17:14
  • @Xantec: 1. Yes, can you put that in an answer (so I can upvote/possibly checkmark it)? 2. How does one get out of the session (i.e. minimize the RDP window) without any way of getting the connection bar? Nov 23, 2010 at 21:21
  • placed in answer
    – Xantec
    Nov 23, 2010 at 21:55
  • 2
    Exact same problem here. But for me, I'd prefer just to make it auto-hide much faster (ideally, immediately when the mouse moves off it). Plus this has the advantage that the auto-hide delay is surely an existing setting specified somewhere (though- worst case scenario, it could be hard-coded). CTRL-ALT-XXX shortcuts are all good, but they're hard to use one-handed, e.g. when your other hand is holding food, or a phone, etc. and you're basically doing everything with the mouse. (A frequent situation for me). Does anyone know how to change the auto-hide timing?
    – Doin
    May 21, 2019 at 8:34

1 Answer 1

18

Edit the connection and go to the Display tab and uncheck "Display the connection bar when in full screen mode".

To get out of the remote desktop and back to your desktop use CTRL+ALT+Break. This will window the RDC.

To go back to full screen use CTRL+ALT+Break again.

1
  • Old answer but wanted to throw my thanks out anyway. Wish I would've known about this sooner, that bar is a major PIA and always getting in the way. Thanks!
    – Hoff
    Dec 16, 2016 at 19:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.