23

The "mouse integration" feature in Virtualbox is pretty handy in most cases, but I need to have it disabled. Unfortunately, it looks like I have to press Host+I at every boot of the virtual machine.

Is there a way to disable "mouse integration" permanently? It would be good if this could be done on a per-virtual machine basis.

6
  • 2
    "Unfortunately, it looks like I have to press Host+I" :'( – John T Nov 24 '10 at 0:52
  • Ok, it sounds whiny, but the point is that I suspect that when mouse integration kicks in, it disrupts my Wacom tablet. But I didn't want to mention that problem because it is irrelevant here, I'll post another question on that :P – UncleZeiv Nov 24 '10 at 0:55
  • Linux or Windows vm? – John T Nov 24 '10 at 0:56
  • I'm using Windows 7 64bit as host and Ubuntu 10.10 64bit as guest. I didn't mention it as I expected it to be a feature of Virtualbox itself... if it exists, that is. – UncleZeiv Nov 24 '10 at 1:12
  • Post your xorg.conf please. – John T Nov 24 '10 at 23:45

12 Answers 12

3

Until now I saw that the auto mouse integration kicks in just on the linux hosts. So disabling it permanently is not possible.

1
  • 1
    If you ever come back, @Darwin's answer does work on linux – Izkata Jan 9 '13 at 21:27
11

This turns it off permanently for me on mac (~2012).

VBoxManage modifyvm "your-vm-name" --mouse ps2

If ps2 does not work for you try the other mouse options ps2|usb|usbtablet|usbmultitouch

8
  • 1
    Just tested it, does NOT work in the latest VirtualBox on FreeBSD. – gravitation Nov 11 '13 at 17:08
  • Maybe one of theas could work on FreeBSD ? Replace ps2 with one of theas (usb|usbtablet|usbmultitouch) – Darwin Nov 11 '13 at 19:53
  • 1
    seems nothing to be working on OS X – Yrogirg Dec 17 '13 at 16:00
  • 5
    @Yrogirg Re: OS X - This is almost a year old, but setting my VM's Pointing Device to USB Tablet like so now achieves the desired behavior for me. – Jimmie Tyrrell Oct 29 '14 at 22:03
  • 1
    Didn't work for me when running VirtualBox in Ubuntu 18.04 – Gabriel Staples Jul 13 '19 at 7:24
3

I have had three problems on a linux host:

If it is not disabled you have to hit Return when VBox asks to go full screen
Mouse de-integration is not automatic (my client nabs the usb mouse directly)
and...
The VBoxControl program in the client savestate command is borked

The following script takes care of all three issues.
It requires you to apt-get wmctrl and xdotool.
Guest additions must be installed.

Change VM_NAME!
Change DISPLAY to whatever monitor you want.
To savestate run "sudo VBoxControl guestproperty set SaveStateNow 1" in a client terminal.

---cut-here---

#!/bin/bash
VM_NAME='My Machine Name'
MAXTRIES=20

export DISPLAY=:0.1
VBoxManage startvm "$VM_NAME" &

i="0"
while [ $i -lt $MAXTRIES ]; do
  echo Fullscreen try $i
  wmctrl -a "VirtualBox - Information"
  if [ $? == 0 ]; then
    sleep 1
    xdotool key "Return"
    break
  fi

  sleep 1
  i=$[$i+1]
done

i="0"
while [ $i -lt $MAXTRIES ]; do
  echo Pointer try $i
  GUEST_ADDITIONS_ACTIVE=`VBoxManage showvminfo "$VM_NAME" | grep "Additions run level" | cut -d : -f 2`
  if [ $GUEST_ADDITIONS_ACTIVE == "1" ]; then
    sleep 1
    xdotool key "Super_R+i"
    break
  fi

  sleep 1
  i=$[$i+1]
done

while true; do
  if [ "`VBoxManage guestproperty get "$VM_NAME" SaveStateNow`" != 'No value set!' ]; then
    echo Saving...
    VBoxManage guestproperty set "$VM_NAME" SaveStateNow
    VBoxManage controlvm "$VM_NAME" savestate
    break
  fi
  sleep 1
done
1
  • It's a bit hacky but pretty interesting. Going to see if I can whip up something similar for a Windows host; will post if I do. – Jason C Jan 11 '20 at 16:26
3

I had this problem using Xubuntu 16.04 running Xfce 4.12 It is driving me insane.

You can go into:

  • Settings
  • Mouse and Touchpad
  • and in Devices Tab, disable the "VirtualBox Mouse Integration" device.
    This permanently disables mouse integration in Xfce.

Disable mouse integration in Xubuntu

1
  • I don't have this dialog in Ubuntu 18.04 LTS. The mouse settings there just have some basic pointer configuration stuff. – Jason C Jan 11 '20 at 16:17
2

I had the same issue, posting for anyone reading this in the future.

From the user manual, Virtualbox has a cmd line VBoxManage utility

VBoxManage setextradata "VM name" GUI/MouseCapturePolicy Disabled

This will disable mouse integration for the specific "VM name".

2
  • Didn't work for me on Ubuntu 18.04 with VirtualBox 5.2.18 – Gabriel Staples Jul 13 '19 at 7:42
  • Didn't work for me with VirtualBox 6.1.0, guest Ubuntu 18.04 LTS, host Windows 10. Disabled seems like the opposite of what I'd want, there's no Enabled option, but also it's a little confusing whether this setting controls default capture, or default mouse integration status (which still requires a click to initially capture when disabled). – Jason C Jan 11 '20 at 16:18
1

Try disabling keyboard auto-capture:

  • In the main window press File|Preferences
  • Select the "Input" tab
  • Uncheck "Autocapture keyboard"

This also disables mouse-autocapture.

enter image description here

3
  • It is certainly better to have this information than nothing at all. Expecting someone to change their entire localization on a volunteer-driven site is silly. – zymhan Aug 20 '18 at 15:10
  • Didn't work for me on Ubuntu 18.04 with VirtualBox 5.2.18 – Gabriel Staples Jul 13 '19 at 7:35
  • Didn't work for me with VirtualBox 6.1.0, guest Ubuntu 18.04 LTS, host Windows 10. – Jason C Jan 11 '20 at 16:19
0

This is probably the same answer as Darwin's, except it uses the menus (to which this option was probably added after his answer was posted):

Open the Virtual Machine's settings, select "System", go to the "Motherboard" tab and change "Pointing Device" to "PS/2 Mouse".

Worked perfectly in my case (Android x86), but 123's comment to Darwin's answer (problems with FreeBSD) may apply here as well...

2
  • Thanks for the answer. Works fine with VirtualBox 5.2.16 on Windows 7 64-bit for virtual Android-x86 :) – AntonK Aug 5 '18 at 16:01
  • Didn't work for me with VirtualBox 6.1.0, guest Ubuntu 18.04 LTS, host Windows 10. – Jason C Jan 11 '20 at 16:27
0

After hours of searching I figured how to fix it and while posting, I saw in comments the same thing. Maybe will help others.

I had to go to VM Settings -> System -> Motherboard and change Pointing Device from PS/2 Mouse to USB Tablet.

2
  • 1
    Didn't work for me on Ubuntu 18.04 with VirtualBox 5.2.18 – Gabriel Staples Jul 13 '19 at 7:44
  • Didn't work for me with VirtualBox 6.1.0, guest Ubuntu 18.04 LTS, host Windows 10. – Jason C Jan 11 '20 at 16:27
0

Go to Machine select settings From the settings window select USB option from the left vertical menu Add your Mouse device clicking the USB+ icon on the right side of the device list( second icon)

Thats it, now your mouse pointer works through out your virtual machine and desktop flawlessly.

1
  • Hrm; I wasn't able to get this working VirtualBox 6.1.0, guest Ubuntu 18.04 LTS, host Windows 10, Synaptics touchpad pointing device. – Jason C Jan 11 '20 at 16:29
0

For anyone looking for a contemporary solution:

From the VirtualBox manual page 9.17.11.

VBoxManage setextradata VM-name GUI/MouseCapturePolicy mode

mode is one of the following:

Default

    The default behavior as described above.

HostComboOnly

    The mouse is only captured if the Host Key is toggled.

Disabled

    The mouse is never captured, also not by toggling the Host Key

On Windows, VBoxManage.exe can be found in the VirtualBox installation directory.

-1

Weird fix for this problem:

  • Click into popup message.

This message expands and show more text and a checkbox field with text Don't show this message again

http://i.stack.imgur.com/z21d8.png

  • Check it and enjoy!
-1

Boot into your VM and find the Input option on your menu bar (it auto-hides by default, should be at the bottom of your screen). Click on the Input option and disable Mouse Integration.

enter image description here

enter image description here

This should be a persistent solution, i.e. you won't need to do it at every boot.

2
  • 2
    Doesn't work (i.e. it's not persistent...) – Markus A. Nov 9 '17 at 2:02
  • This is just the GUI equivalent of the OP's attempt (the OP had Host+i assigned to that menu item); it's not really a solution, it still presents the same issue. – Jason C Jan 11 '20 at 16:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.