0

On a fresh EC2 instance running Ubuntu, I see that there's no /etc/init.d/sshd file. I tried

sudo apt-get install openssh-server

And it shows that openssh-server is already the newest version. How do I get the /etc/init.d/sshd file?

3

Ubuntu is now using Upstart to do the init and /etc/init.d/ job. Instead of writing /etc/init.d/sshd $ACTION you are now supposed to write service ssh restart or just restart ssh. Note that it is called ssh, not sshd.

1
  • Thanks, this is the correct answer. The sshd in not present in ubuntu 14.04 server, i ran sudo service ssh restart and it work.
    – Ibn Saeed
    Jun 15 '14 at 7:42
2

On my Ubuntu installation it's /etc/init.d/ssh

Try

dpkg -L openssh-server | grep init.d
1

Maybe they switched the ssh service over to Upstart config files. Look in /etc/init/.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.