I have a fairly strange lock up problem with a Windows Vista Business installation. When I run a specific application, and only that application, the system freezes completely. I'm looking for advice on how to precisely identify and eliminate the issue.

Specific details of the symptoms and what I've tried so far:

The system is a Dell Latitude D630 with 2GB RAM, all drivers are up to date and the system is fully patched.

When it occurs the OS is completely frozen. Mouse and keyboard are unresponsive and any on screen activity ceases. Remote connections to the system fail. Pings timeout. The only way to get out of this is to hard power down the system. I've left it to see if it would time out but after more than an hour in the same state I decided that it wasn't likely to come back.

The problem is only caused by launching the VMWare VI Client. I use this system constantly and nothing else appears to trigger the problem. Running multiple apps attempting to stress the system isn't a problem. Very shortly after the VI client successfully authenticates to either an ESX\ESXi Host or a vCenter\Virtual Center server the system locks up. The precise stage at which it freezes varies slightly but it always succeeds in causing the problem. Completely uninstalling\reinstalling the VI 3 Client makes no difference and upgrading to the VI 4 Client makes no appreciable difference; the lockup timing is different but it still occurs. The same software on identical hardware with (as far as I can tell) an identical Vista Business installation does not suffer from the problem.

The event log entries that get recorded give no indication of any consistent or related activity that I can see, just an event log entry stating that the previous shut down was unexpected.

Edited to add After some further testing I've established that the problem only occurs when I'm directly connected via a LAN connection to the network that the target VMware systems are on. If I'm connected remotely (ie tunnelled in via VPN over a wireless connection) the lock up does not happen. I'm not currently able to test if the problem does not occur if I'm just connected via a wireless network as I don't have a WLAN that directly routes to the systems in question.

4 Answers 4


I had the same issue a few years ago on a Dell laptop, I couldn't for the life of me figure out what caused it.

Do you have UAC on or off? With UAC on, at certain parts of the program, it would prompt and if I clicked allow, it would freeze, if I did deny, it worked fine! With UAC off, it auto allows everything and instead of prompting you, at the parts that require elevation would just freeze.

I needed to get it working urgently and in the end, I just ran VI client inside of another VM on VmWare Workstation.

I attributed it to (but never confirmed) a conflict with my network driver (Realtek RTL8101E). Different versions of driver did not fix it, however now I am on Windows 7, I can use VI fine, without any problems.

  • Interesting - I think you might be on to something with this. I have UAC off by default on this system.
    – Helvick
    Sep 10, 2009 at 20:21
  • Try turning UAC on just for a moment and re launch, see if it works if you do deny when asked, and then see again if it freezes up the moment you click allow - if it does, this is the same issue I had! Sep 10, 2009 at 21:41
  • I tried this and it didn't make a difference but it's still a very interesting potential problem that I'll be keeping an eye on in future. What I've now found is that the problem does not happen at all when I connect over a VPN tunnel (via wireless) but it does happen when I'm directly connected to the LAN so the idea that the root cause may be related to the LAN adapter\driver still looks very plausible.
    – Helvick
    Oct 3, 2009 at 18:36

Given your explanation, it's quite possible (or even likely) that the problem lies with this application. Have you looked to see if there's an updated version of this application? Or look on the application vendor's website to see if this a known issue?

  • I've tried the updated versions - the problem remains, presumably the component that is causing this is not being updated.
    – Helvick
    Sep 10, 2009 at 20:19

Have you checked the Windows Event Logs after a freeze? You only mention checking VMWare Client's logs. Control Panel >> Administrative Tools >> Computer Management >> Event Viewer.


I'm not sure if this would persist past the system freeze, but you can log system activity with Sysinternals Process Monitor.

Make sure you save the log in native .PML format, and you'll be able to view process, file system, and registry activity for your application.

If the log file survives the hard reset, you can open it directly in Process Monitor for analysis.

  • I'm going to give this a shot but it's going to be about a week before I'll be able to test this. The issue only arises when I'm directly connected to a LAN - for some reason it doesn't happen when I connect remotely over a VPN.
    – Helvick
    Oct 3, 2009 at 18:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.