9

My outlook 2010 inbox shows a count of 3 unread messages, but there are no unread messages in the inbox.

There is no view, no filter on the inbox.

Do you know a way to force re-calculation of that count ?

Thanks

16 Answers 16

7

Sort your emails by latest date, and look for any unread items in your inbox. If you are certain no unread emails exist, mark all messages as read:

  1. In the Navigation Pane, click the folder.
  2. On the Folder tab, in the Clean Up group, click Mark All as Read.

Keyboard shortcut: Click any message in the message list, press CTRL+A, and then press CTRL+Q.

Make sure there are no rules enabled or set in your inbox!

This issue can happen if the mailbox is just set-up and/or the connection to your Exchange server is slow.

3
  • Thank you for your advice. The mailbox us just setup, but the connection is quite fast (I'm not connected over the internet). Another "funny" fact is that Select All (control+A) does not work on this mailbox (but in all the others, it's ok).
    – Laurent K
    Nov 29 '10 at 9:03
  • 1
    I found a sort of solutions... In Account Settings/(my account)/Server Settings/More Settings/Advanced, I checked "enable cached exchange mode", event if I did not need it. And then, my unread count was right.
    – Laurent K
    Nov 29 '10 at 9:38
  • 1
    I have had a stuck '1 unread message' indicator for weeks: disabling then re-enabling Cached Exchange Mode finally fixed it - thanks
    – stuartd
    Mar 1 '13 at 12:01
3

I did the advanced search for 'unread' and it found the 4 that my inbox had.

They were empty content emails.

I was able to delete them from the search window and now all is well.

1

I sometimes accidentally collapse the view so that a particular day appears to have no emails when there are actually some there. Are you sure you haven't got a plus sign showing next to any of the dates?

1

I had the same issue with Office 2011 for MAC. Finally resolved it. If you do an advanced search based on "read status" you will find those unread messages in your one of your mailboxes.

I identified the problem to be the mismatch of the available trash (or deleted items) mailbox with the mailbox defined in "where to send deleted items" field. I resolved it through the following steps: 1- Setup the IMAP account in another mail program. 2- Re-define/re-assign the trash/deleted items mailbox 3- Deleted the old trash/deleted items mailbox 4- Refresh the settings in outlook 2010.

Voila. Unread counter works perfect...

1

Right click the Inbox folder; then, select Mark All as Read. It worked for me.

1

If possible try to connect to OWA (Outlook Web Access) and mark all items as read in the OWA. This will help to sync this back to your local Outlook.

1

Another answer found on the Microsoft forums:

Try Control-Clicking your Inbox in the folder list and choosing Folder Properties > Empty Cache.

This ends up forcing Outlook to download all e-mails again, and may also help with the unread count. It did for me!

Note that this solution really does force all e-mail to be re-downloaded, so, if you can, you want to do it on a fast link, or on a small mailbox.

1

Please make a backup of all your messages by creating a new folder and moving the messages to the folder from inbox. Clear the inbox and Update the inbox folder the count will be removed.It worked on my outlook 2013.

1

You can type read:no in the search bar, and all unread messages will show - I even had a message I had replied to show up in this search - it will work on mail items that are not displaying properly as well!

1

The unread email is there but Outlook 2010 doesn't show it. Open the OWA for the account and you will see the unread mail, why outlook 2010 is doing this... I don't know. But it has something to do with Cache settings, filter or mail on private setting.

Conclusion: Check the OWA first of the mailbox with the problem. If there is no unread mail, then you can apply the solution above (mark all read).

I did the same before, we just had the new Outlook and Exchange server 2013 and I had this problem also. I marked all mail read, but a customer called very angry, well you can guess what the problem was.... Nobody replyed his mail because I marked it to read.

0

What type of account are you using? I've experienced similar problems running Gmail on IMAP and I've had to browse through some of the GMAIL IMAP folders to find the unread messages.

If you're running POP3 try creating a new folder which filters in all unread messages from any folders to see if some pop up.

Worse-case, you might have to rebuild your user profile by deleting a re-creating the account from the account settings panel.

Still, chances are that there is some unread message somewhere that you just aren't seeing. Check through all of your folders.

2
  • In fact, there is no IMAP or POP3. I'm connected to a MS Exchange server.
    – Laurent K
    Nov 25 '10 at 13:00
  • Exchange servers sometimes have the same effects as IMAP servers in terms of handling "unread" mail, especially if you access the Exchange Server from other devices such as hand-helds. Check out the reply below and follow the instructions for select all mail and then right lick and "mark as read". This might solve your issue. If not, we'll keep looking into it.
    – akseli
    Nov 25 '10 at 15:41
0

I had this issue in Outlook 2013 using Outlook.com (Corporate) . I right clicked my inbox, and chose properties. Then clicked the Clear offline items.

I then did a send/receive to repopulate my inbox. When it was done, the count was corrected.

0

I also was having this issue, I tried recreating the profile issue came back about 1-2 months later. Quick fix that worked for me, was switch it to "Show all Items count" exit outlook. wait till outlook fully closed. re open outlook then switch it back to "show unread items count".

I had to do that procedure about 3 times. This issue only occurs when in cached mode and for me, it was happening only on the secondary mailbox not the primary.

0

I have had this happen to me twice now. One solution is posted here (see Tog from November 25 2010, "I had a collapsed day that had some unread messages in it." Also had another issue where I had hidden messages. I had to type in the search bar "UNREAD", which then shows the hidden unread messages that seem to be lost in the exchange server. This brought them into my machine so I could work with them. I found that on the Superuser site a few weeks ago. I can't take credit for either of these fixes but thought I would add to the info on this question.

-1

Right click on folder properties >General, select between Show total number of items or Show number of unread items

-1

All the above listed failed in my case. Finally i right clicked on the folder that shows unread mails and chose properties. Under the permissions tab, i made some changes in the permission level then it worked well... Hope it will help you... Give it a try :P

2
  • 1
    "Some changes"? What changes? Also please note answers have no fixed order, thus "all the above listed" is ill-defined. May 29 '18 at 9:15
  • This answer may be wrong and it appears to be incomplete. But it is an answer.
    – Scott
    May 29 '18 at 11:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.