6

On widescreen Windows 7 desktops, I prefer a vertical taskbar with small icons. However, this appears to remove the date from the clock display.

Here's what it looks like, missing the date.

clock without date

How can I get the date to display again?

11

On my widescreen system (Windows 7, 1440 x 900 resolution, small icons), I have both the date and the time:

alt text

It may be a resolution problem perhaps? Or, your taskbar is too thin to allow for both? Try looking in the Taskbar Properties...

8

I'm going to accept studiohack's answer since it is basically right. However, there's a little more information so i'll post it here.

It does appear to be resolution dependent. I had the "Appearance and Personalization" / "Display" setting set to Medium - 125% (default).

Changing that to Smaller - 100% fixes the problem and as a bonus it throws the day of the week in there too, but makes things very very small.

alt text

So, what to do? Well, back at the Medium 125% setting, i changed the short date format to M/d/yy and it's pretty close to what i want.

alt text

So, thanks for the suggestions. Got me pretty close. Any other thoughts on tweaking the date display here would be appreciated.

4

Try going to Taskbar Properties, click Customize and select Restore default icon behaviors. The date should be displayed by default, no matter what part of the screen you select for your taskbar. I just tried every possible combination and I always get the date right below the clock.

As studiohack suggested, It might be a resolution problem, could you post your default screen resolution?

  • Hmmm... 1920 x 1080 with ATI Mobility Radeon HD 4670 on this laptop, but i've got the same problem on other systems. I usually have the highest resolution selected, with ClearType on and tuned, if it matters. – b w Nov 26 '10 at 18:42
2

On both computers on which I have used Windows 7 (with 1440x900 and 1366x768), it's simply a case of how wide the taskbar is - widening it will cause the date and day to appear automatically.

2

Right click the taskbar --> properties --> Uncheck "Use small icons" --> the date will appear also.

  • 5
    Oh no, that's awful. Thank you, but that's horrible. I'm not interested in enormous gigantic icons on the task bar. Wow, my eyes hurt now. :) – b w Jun 28 '13 at 13:49
  • I don't see the date even with this unchecked. – Neil Smithline Nov 17 '15 at 18:57
1

Combine the tips from here: http://www.howtogeek.com/194103/how-to-put-the-day-of-the-week-into-the-windows-taskbar-clock/

With this awesome little efficent tool: http://rammichael.com/7-taskbar-tweaker

Will let you make the taskbar showing dates exactly like you want. Dont forget to activate "no_width_limit" in advanced settings of 7TT

By default, Windows limits the minimum width of the vertical taskbar. The limit might seem too restrictive for some, so this option removes it. 0 - Disabled (default), 1 - Enabled

I could unfortunatly not add an image due to too low reputation to show how i have it.

This works with Windows 7, 8, 10.

0

If you're using Windows 7, right click on the desktop - Gadgets - Calendars. this will add a gigantic date in your desktop. I prefer this rather than widening your taskbar (so ugly) or using large icons (uglier).

Cheers.

0

Use T-Clock from https://github.com/White-Tiger/T-Clock

I've used this release https://github.com/White-Tiger/T-Clock/releases/tag/v2.4.2%23459-beta and works on Windows 7:

enter image description here

No need to use large icons in taskbar.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.