I'm using Ubuntu Studio 10.10 x64. I want to get wireless networking going manually. My wireless networking works successfully in Windows 7 x64.

I've also posted this question at http://ubuntuforums.org/showthread.php?t=1630949, and some information is only on that post due to the size limits of Super User questions.

I can get wireless working successfully without encryption but when I try and use WPA-PSK, wpa_supplicant gets stuck in a loop between GROUP_HANDSHAKE and COMPLETED, as shown in the log attached to the Ubuntu forum post.

I've been working mostly off the instructions in this post: http://ubuntuforums.org/showthread.php?t=571188

My laptop is a Dell Studio 1537. It has an Intel Wifi 5100. I'm connecting to a F5D7633-4 router running F5D7633-4Av1_UK_1.00.010 firmware, which is the latest version of the firmware I can find. When I set up WPA, it uses encryption technique TPIK.

The other generic information is provided in the Ubuntu forum post.

My wpa_supplicant.conf file is (I've also tried with the commented lines uncommented).


    psk=**big hex string**
#    pairwise=TKIP
#    group=TKIP 

I've been using this script to try and get wireless enabled - the script worked with the wpa_supplicant line commented out when I had encryption disabled on the router

service networking stop
ifconfig wlan0 down
dhclient -r wlan0
wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf -dd
ifconfig wlan0 netmask up
route add default gw
ifconfig wlan0 up
iwconfig wlan0 mode Managed
dhclient wlan0

This resulted in the log attached to the Ubuntu forum post

I'm stumped and have lost a lot of time trying to get things going. Any help would be greatly appreciated.


You must log in to answer this question.

Browse other questions tagged .