I'm trying to install the Lexmark X1290 printer on a 64-bit Ubuntu 10.10 system. I previously had this printer working flawlessly on a 32-bit Ubuntu 10.04.

I'm following the instructions from http://www.trodrigues.net/wiki/linux:ubuntu:lexmark_x1290 and using the Z600 series driver from Lexmark.

Create a directory named lexmark and unpack the driver:

mkdir lexmark
tar -xvzf CJLZ600LE-CUPS-1.0-1.TAR.gz

Extract the driver from the install script:

tail -n +143 z600cups-1.0-1.gz.sh > install.tar.gz

And untar it:

tar -xvzf install.tar.gz

This generates 2 drivers (z600cups-1.0-1.i386.rpm and z600llpddk-2.0-1.i386.rpm) that then should be converted to .deb files with alien and installed with dpkg, but -as the filenames already indicate- the drivers are for 32-bit systems and not for 64-bit systems. Hence the error:

$ sudo dpkg -i z600cups_1.0-2_i386.deb 
dpkg: error processing z600cups_1.0-2_i386.deb (--install):
  package architecture (i386) does not match system (amd64)
  Errors were encountered while processing: z600cups_1.0-2_i386.deb

Any idea how I can get this to work?


I'm not familiar with this driver, but you could force the installation by running:

sudo dpkg --force-architecture -i z600cups_1.0-2_i386.deb

It might still not work, but it's worth a try.


Here is additional information needed as of 2018 (that is, to install Lexmark X1290 printer on Ubuntu 18.04):

  1. The procedure fails at alien invocation on a 64-bit system:

    z600cups-1.0-1.i386.rpm is for architecture i386 ; the package cannot be built on this system

    I could "fool" it by converting to .tgz format first, then to .deb:

    sudo alien -t z600cups-1.0-1.i386.rpm
    sudo alien -t z600llpddk-2.0-1.i386.rpm
    sudo alien z600cups-1.0.tgz
    sudo alien z600llpddk-2.0.tgz

    After which the installation worked:

    sudo dpkg -i z600cups_1.0-2_all.deb 
    sudo dpkg -i z600llpddk_2.0-2_all.deb
  2. The z600 backend and rastertoz600 filter need the 32-bit versions of specific libs. I had to install libstdc++5:i386, libcups2:i386 and libcupsimage2:i386.

  3. After restarting CUPS, I did not have to manually select the PPD file. Model Z600 showed up in the list of Lexmark models.

(Steps taken on Linux Mint 19, based on Ubuntu 18.04. Answer originally posted on Ask Ubuntu, where this question was duplicated.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.