2

When I try and install SQL Server 2008 Developer Edition, it stops and says I need .NET 3.5 SP1.

Windows 7 has .NET 3.5 installed (I selected it in features) but I guess it's not SP1? (I'm running Windows 7 Ultimate RTM).

I tried installing .NET 3.5 SP1, but it just stops after I click on the .exe.

Ideas?

Error: .NET 3.5 installation has failed. SQLServer 2008 requires .NET Framework 3.5 to be installed.

I have already installed Visual Studio 2008. I have selected 3.5 in programs/features (I checked the main checkmark, there are 2 sub-checkboxes that I didn't select)

6

SQL Server 2008 Developer Edition includes the installer for Framework 3.5 SP1 and should automatically install the Framework before launching the wizard. There is a known problem with Windows 7 and SQL Server 2008 since it requires SQL Server 2008 Service Pack 1.

However this blog post as well as this discussed the problem at length with links to the KB articles with regards to installing SQL Server 2008 on Windows 7.

  • the first blog post suggestion (run dotnet35setup with windows vista sp1 compatibility) doesn't work either, it fails with a cryptic "setup error" – lurscher May 3 '12 at 16:10
4

Windows 7 Final includes .NET 3.5 SP1

0

Make sure you're installing from an account that has administrator priveleges.

Also, if you're on a domain, make sure there aren't any group policy restrictions in place. I've encountered the error you're getting when attempting to install Visual Studio as a user with local admin rights, because there was a group policy restriction preventing access to the security log (which the .NET installer needed access to, for some reason).

  • Actually you can always right-click any EXE and select "Run as Administrator" to elevate its privileges. – Chris Pietschmann Aug 16 '09 at 6:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.