It is a known issue with Thunderbird 3.x that it downloads duplicate emails. I installed Thunderbird 3.1.5 last month (it's awesome!) and configured it to not download duplicate emails using the following well-known solution, this all worked fine until last week:

  • set Tools->Options->ConfigEditor->Advanced:mail.server.default.dup_action = 1
  • (Email account)->Server Settings: enable 'Leave messages on server', 'Until I delete them'

Also as a manual fallback I installed the add-on 'Remove Duplicate Messages (Alternate) 0.3.5' by eyalroz, which works well.

Everything worked fine until last week (you never see duplicates because Thunderbird deletes them on-the-fly), then last week it started getting duplicates again, despite the settings. We're talking downloading 9000 duplicate emails here every single time it checks mail, it's nearly unuseable. (FYI I access Hotmail via POP. On Vista.) (Yes I already read the Help, FAQ, Release Notes, Bugzilla, superuser.com archives and googled the web. Many reports, few solutions and none that work 100%.)

In the Thunderbird Bugzilla, there are many bugs over many years for 'duplicate email', but the main culprit for my issue might be Bug 608242 - "Hotmail still downloading duplicate messages". Then again it might not be, it might also be 284526, 591334, maybe 612136 or other. To get these bugs more prominence, register on Bugzilla and vote for them. There are many other manifestations of duplicate mail in TB, so do not start arguing that the culprit is Hotmail and not Thunderbird itself. TB should be able to handle this robustly, no matter how crappy Hotmail might be. The underlying root-cause sounds like the hash file 'popstate.dat' in which TB keeps a hash of message date, time, sender, subject etc. and checks it before downloading. Many of the Bugzillas suggest popstate.dat may be being corrupted, e.g. by (AVG) antivirus. There are also reports that filtering or attachments also tickle this. Anyway as I commented, this all used to work fine for me till recently.

Any solutions, workarounds or suggestions?

  • Are you using a hotmail account?
    – Force Flow
    Dec 5, 2010 at 3:24
  • Yes, I said: 'FYI I access Hotmail via POP'
    – smci
    Dec 5, 2010 at 22:55
  • I don't have TB sync'd with hotmail, but here's how it happens for me. I get my mail on TB on my desktop, FINE, then if I go and get it on TB on the laptop... fine too. But when I go back to the desktop, it will download EVERY single mail the laptop has just downloaded, ALL OVER AGAIN. It only happens like that for me, if I get the mail on the laptop, the desktop will get them all over again. I have the same version of TB and they have different features (QUITE WEIRD), one has a "Synchronization" option and the other "Disk space". O.o 3.1.10 on both. This is kind of weird.
    – user83540
    May 29, 2011 at 20:54

2 Answers 2


As for version

  • 45.2.0 Ubuntu 15.10
  • 52.6.0 (32-bit) Windows 10

The following helped me:

Got to Preferences (or Options, depending on version) -> Advanced -> Config Editor.

Hit the "I accept the risk!":

  1. Search for dup_action.
  2. Double click on mail.server.default.dup_action and set value to 1.
  3. Click OK.
  4. Depending on the version/OS you'll need to close the Advanced Config Window manually.
  5. Restart Thunderbird.
  • Thanks but as I recall this didn't solve it fully.
    – smci
    Dec 20, 2020 at 8:25
  • @smci I really can't remember. This too long ago. I switched back to Outlook as some other things were annoying such as formatting, filter rules etc. If you found out what is needed to solve this completely, feel free to add your answer.
    – toesslab
    Dec 20, 2020 at 12:23

i'm not sure if this will help, it seems trivial, but i had the problem of duplicate emails in my sent box only. After all manner of things to solve this i ended up opting to turn off (uncheck) 'Place a copy in' under Account Settings -> Copies and Folders, thinking this would stop this irritating bug for a while as what i was sending was not that important. The bullet for 'Sent Folder on ' was however checked, just greyed out for deselecting 'Place a copy in' . For doing this i expected to have no copy of any email i sent in my 'sent box'. However this is not the case, i receive just one copy in my sent box. I hope this information helps somehow in relation to the problems you are having. Thunderbird 24.5.0 Hotmail/Outlook imap enigmail 2:1.5.2-0ubuntu0.12.10.1 ubuntu 12.10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .