When starting my MacBook Pro this morning, Eclipse says:

Workspace in use or cannot be created, choose a different one

and Netbeans says:

The Source folder /Volumes/data/domains/... cannot be restored.

I have deleted the .lock file out of my metadata directory in the eclipse workspace, and afterwards restarted the computer, but still have the problem:

alt text

In finder I can navigate to the workspaces no problem, those volumes are connected.

I am quite certain I didn't have Eclipse and Netbeans open when I closed the computer as I am aware that it causes these problems.

In configuration/.settings/org.eclipse.ui.ide.prefs I tried changing the RECENT_WORKSPACES entry but this didn't have any effect.

How can I get Eclipse and Netbeans to recognize their workspaces again?

  • 1
    Have you mounted multiple volumes with the name "data"? What is the output of ls /Volumes? Have you tried selecting the workspace when prompted to do so in Eclipse (I have no experience using Netbeans)? – Daniel Beck Dec 6 '10 at 16:31

The problem turned out to be that for some reason the volume name was changed from data to data-1, perhaps because it was offline and automatically renamed it. The solution was to disconnect (pulled cable), disconnect all, reboot, then data-1 was gone, then pointed Eclipse and Netbeans to data again and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.