I've just experienced a very weird bug. After installing Dropbox 1.0RC over 0.7.112, my taskbar buttons have disappeared:

alt text

As you can see, none of the open programs have a button on the taskbar, so I have to alt-tab to switch. But win+n shortcut still works for the pinned programs. Changing various taskbar settings (position, grouping etc.) didn't help. I tried restarting explorer.exe and then rebooting. Didn't help. Turning off Dropbox and reinstalling it didn't help either, obviously.

UPDATE: Everything seems fine on a guest account; disabling Aero doesn't help, the buttons are not "hidden" by a toolbar.

I also think it's not a graphical glitch, because I tried most of the tips for the "missing taskbar" problem and nothing works. I simply don't have any buttons between the start orb and the tray.

UPDATE2: The problem still exists in safe mode.

UPDATE3: Command-line tool sfc didn't find any corrupted resources.

Is there a way to reset my user profile settings without destroying the whole profile?

  • 1
    do you have another computer running the same OS? If so, you could replace explorer.exe, which sounds like it may be corrupted Jan 29, 2012 at 17:17
  • So what ever did happen to this, out of curiosity?
    – nhinkle
    Mar 17, 2013 at 20:46
  • @nhinkle I gave up and reinstalled windows from scratch.
    – Greg
    Oct 3, 2013 at 9:54

2 Answers 2


Have you checked if you have locked toolbars that could be hiding that?~ Have you tried disabling Aero? Have you tried to login with a different user?

UPDATE Check if this helps:

  • No toolbars are messing with that (all disabled, tried unlocking the taskbar and resizing/dragging everything). Switching to the Basic and Classic styles didn't help either. But everything seems fine on the guest account.
    – Greg
    Dec 6, 2010 at 14:59
  • Nope, still nothing (too bad I have disabled Sys Restore, might help this time :/)
    – Greg
    Dec 6, 2010 at 15:54

Try starting your machine in safe mode, if you still have it, I am not entirely sure what it is, but most likely something in your actual user profile/account is corrupt.

If however you do not have it there then we can rule out anything weird such as your account/profile being corrupt and it is most likely just software that was installed for your user alone.

You mention that dropbox was most likely the cause, you said "turning it off didn't help", I would try a full uninstall of it from safe mode, then a restart.

If however you still have it, I would recommend launching Microsoft / Sysinternals Process Explorer and trying the search/find process tool (looks a bit like a circle) and drag it to the taskbar, it should show you what the process is. If it is anything other than explorer.exe, please say here.

Hopefully this will put you on the correct track, however there are many different routes to try next but to be honest, I am not sure what is the best to recommend, so please give some feedback as to how far you get and I will try to help you further.

  • The problem still exists in safe mode. Unfortunately I uninstalled the app that caused the problem earlier, in normal mode (didn't help). The taskbar is running as explorer.exe.
    – Greg
    Dec 7, 2010 at 9:10
  • As it does happen in safe mode, I am not really sure the best way to help you other than to say to create a new profile and copy everything over. Sorry :( all my answers were based on it not happening in safe mode. Dec 7, 2010 at 9:23
  • Is there no way to reset my current profile? For example, by deleting some files (ntuser.dat and it's brethren?), or some registry keys?
    – Greg
    Dec 7, 2010 at 17:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .