My Lenovo T61 has a dual core CPU. I just noticed that under Ubuntu 10.10 only one CPU is recognized. I know that once both CPUs worked. Not sure since when the second CPU is missing. Maybe since the last kernel update. Currently I am using linux-image-2.6.35-23-generic (for x86_64).

What can I do to enable the second CPU again?

Here the ouput of /proc/cpuinfo

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 23
model name : Intel(R) Core(TM)2 Duo CPU T8100 @ 2.10GHz
stepping : 6
cpu MHz : 800.000
cache size : 3072 KB
physical id : 0
siblings : 1
core id : 0
cpu cores : 1
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 lahf_lm ida dts tpr_shadow vnmi flexpriority
bogomips : 4189.99
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

Any help is welcome. I really need that CPU power for my work here.

  • What does /proc/cmdline contain? Dec 6, 2010 at 15:02
  • 2
    I found the problem ... it is the current Nvidia driver ... not the one from ubuntu but the official one. It does somehow disable the second one. I go with the Ubuntu drivers for now and test things a bit futher when I have the time.
    – medihack
    Dec 6, 2010 at 15:31
  • 2
    You should really convert the Update to an answer and accept it. This way it will be clear what are the problem and its answer.
    – harrymc
    Dec 6, 2010 at 16:29

3 Answers 3


The current Nvidia driver (the one from Nvidia itself "NVIDIA-Linux-x86_64-260.19.21") leads to those problems. After uninstalling it and installing the one of Ubuntu again the second CPU shows up again. Not sure why that driver has this problem, but I will test things a bit further when I have the time.

  • 1
    That driver may have issues with SMP in the kernel, and the kernel may be falling back to uniprocessor to avoid being unusable.
    – TuxRug
    Jan 15, 2011 at 5:01
  • 3
    If this solved your problem, then you should accept it.
    – AndrejaKo
    Jan 15, 2011 at 5:21
  • 1
    ^ It solved my problem as well so ... :)
    – mike3996
    Feb 26, 2012 at 8:37

I noticed that I had this problem right after I performed

    sudo pm-powersave true

I inverted it, restarted, and my laptop now recognizes my 2 cpus. (For completeness...)

   sudo pm-powersave false

I performed this on:

MacbookPro 5,2

Ubuntu 12.04 LTS

Intel Core 2 Duo


I also experienced the problem of the missing cpu with a Core 2 Duo Asus N90S notebook and Ubuntu 10.10. Also, the system would only boot the LiveCD and finished installation with "nolapic" in the kernel params. Under 9.10 the system behaved normally.

Under 10.10, removing the NVidia driver did not fix the missing cpu for me and isn't the only problem.

After reading some other cases of this I had a feeling a kernel compile was in order.

I grabbed the official ubuntu linux kernel source module and compiled a new kernel, with the correct CPU type selected, Power Management disabled and CPU_HOTPLUG disabled. Installing that kernel brought back the second cpu, and ability to correctly boot up without the special "nolapic" setting.

I'm posting this in the hopes it will be useful to other people having problems.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .