I can't connect to public, unencrypted WiFi at my local public library or Peets Coffee.

Setup: Late 2006 MacBookPro running 10.5.8. I have Parallels installed.

It's supposed to work like this:

  1. Connect to their unencrypted WiFi network
  2. Open a browser which redirects you to their "enter password/agree to terms" page.
  3. Browse normally.

I can connect to the WiFi network, but when I try to authenticate I always get stuck in a redirect loop. It's been like this for a while. Even before I upgraded to 10.5.8.

I never have trouble with encrypted networks or regular open WiFi.

What I've tried:

  • Disabling Parallels connections in Network Prefs. Superstition: somehow Parallels installed something in the network stack that's messing me up.
  • Pinging the IP address of the WiFi node I'm connected to. I can ping it, it's there, but I still get stuck in this authentication redirect loop.
  • Tried different browsers, tried different cookie and security settings. Even tried IE under Parallels. No dice.
  • Tried flushing DNS cache.
  • Asked library and coffee employees for help. It didn't go well.

What should I be looking for?


4 Answers 4


There is a thread on Apple Discussions for this issue: Public wifi hotspot problems.

A suggestion:

Nothing in your MBP is seriously miss-configured. Most times it's the service. What I do is to create a new location for every public hotspot I visit. Outline the preferences along with ISP (network names) in my Preferred networks list.

If a hotspot reacts like the one's that are giving you issues I manually type the hotspots sign-in page in the url address in my browser. Once there I can bookmark that page for the next time it gets buggy.

  • While there may be a technical problem with the service, I don't think we can put all or even most of the blame there when most other computers connect to it correctly. Still, +1 for having the best fix suggestion. Aug 25, 2010 at 14:05

I had a problem like this getting web access on the guest network while on a recent visit to a client's HQ building. In the end, having tried everything else I could think of, I restarted the machine (2008 MacBook, 10.5.7) after having joined Airport to the network and it connected to the auth page first try. I've no idea why this worked, but it may be worth a go.

Regarding your Parallels superstition, I have VMWare Fusion installed. Might be relevant, might not... hopefully someone else will come up with a definitive answer...

  • Interesting, I will try this. Unfortch I'm not in a coffee shop every day so I can't hammer on this problem like I could if it was a home network problem :-) Aug 14, 2009 at 19:55

I had this issue with my 2006 Macbook Pro. I took it to an Apple store where I was told it's an internet card issue and they charged me $95 + $85 labor to replace it.

My feeling is the card was defective to start with. I had problems with Wi-Fi from the very beginning.


This seems to be an issue with AutoFill functionality in Safari. I got MacBook Pro running Mountain Lion and used to face same issue. My Hotel has free WiFi that asks user connecting to WiFi to click on some agreement before connecting to WiFi. Solution: I went to Safari preferences (Safari Menu>Preferences>AutoFill Tab) and unchecked all the Autofill settings checkboxes. and Voila I never enter into any redirect loop and can connect easily.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .