I have a PC that my colleague tried to switch from domain membership back to workgroup a short while ago. I corrected most of the ensuing chaos with a system restore, but now although the PC seems to think it belongs to the domain, when I try and log on with a domain account, I get the message:

"server does not have a computer account for this workstation trust relationship".

I'm guessing that on leaving the domain, some account was removed from the domain server. What can I do to correct this?

  • The account is probably there they're just out of sync...looking around a bit for the reset computer account howto – RobotHumans Dec 8 '10 at 11:56

First make sure the computer account is actually in AD look for its DN, next you can try

dsmod computer ComputerDN -reset
more discussion of dsmod for resets is here: http://technet.microsoft.com/en-us/library/cc778276%28WS.10%29.aspx

if you use groups to manage policy and don't have a lot of policy directly on that PC, you could just delete the computer account and rejoin it to the domain manually - not recommended if you don't know what how corporate wide policies are applied

  • I've just reset the computer using the console on AD, and yet I still get the same error. – ProfK Dec 8 '10 at 13:12
  • hmph...there's a way to force something similar to a new add, i can't remember at the moment...it's in the mcitp ent admin server study guides. – RobotHumans Dec 8 '10 at 13:14
  • Oops, I didn't notice the computer was disabled in AD. I now get an incorrect password error despite resetting the password twice, but that's another question. – ProfK Dec 8 '10 at 14:00

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.