I've been trying to run a CUDA program on a remote computer which has Windows 7 installed. The GPU is GeForce GTX 480. One of the problems I've been facing is that, the computer has two adapters,
1) Standard VGA Adapter
2) NVIDIA GeForce GTX 480

Even though this shows in the device manager. The desktop uses the standard VGA Adapter. I'm assuming this is because the Standard VGA is the primary adapter. Also the device manager shows that the monitor is connected to the standard VGA Adapter. In this scenario if i try to run any CUDA application it fails to recognise a CUDA capable device.

Is it necessary for the NVIDIA adapter to be the primary one? Or is there any way to use CUDA when the graphics card is a secondary adapter. I've seen a few posts in the NVIDIA forums on this before, one suggests using another low cost NVIDIA card as the primary adapter, but that is currently not an option. I couldn't find any other solutions.


I tried running the deviceQuery test from the NVIDIA GPU Computing Samples. This was the result i obtained

CUDA Device Query (Runtime API) version (CUDART static linking) cudaGetDeviceCount FAILED CUDA Driver and Runtime version may be mismatched FAILED

The driver version I'm using is 263.06. The CUDA version is 3.2

I ran the same test on my desktop which also has windows 7 and a GeForce GTX 465. The CUDA toolkit version is 3.2. The driver version was the same and the test passed, although it failed with an older driver.


Check you BIOS, you can usually configure what should be used as your primary video adapter there and I suspect it is misconfigured - it should be set to use PCIe-16, and not the onboard.

You may find that changing this configuration option will hide the onboard adapter from the OS entirely (it does on my machine, for example).

  • Thanks, I had to make it the primary adapter for the time being, though I really wanted to use the GPU just for CUDA Dec 9 '10 at 13:09

It shouldn't need to be the primary adapter. It might be how you are trying to grab the device...I would try getting the dev tools for cuda installed on the PC in question and using the enumeration utility and posting the output if it fails.

another note, in some drivers CUDA functionality is disabled despite the fact that the card is capable of it.

it looks like the gtx480 might not be supported by the 260 inf out of the box. a discussion of similar problems to yours is here: http://lunatics.kwsn.net/12-gpu-crunching/split-powerspectrum-unit-test.msg33737.html;topicseen

in this discussion at least one user has the gtx480 running as a non-display adapter and doing cuda processing with it:

@Ghost: I did get the following so far:
- Made the modifications appropriate to the inf file, and successfully installed 263.06 TCC driver ( On 480 )
- Disabled the device as a 'normal' display (using mobo display instead)
- Merged the nSight registry key that disables WPF acceleration (for good measure, shouldn't be necessary with no active display on it)

Next step should be to switch the devices driver mode to TCC mode.  That's done via the command:
  nvidia-smi --driver-model=

howevr I get this response:

ultimately some users had success with a patched inf from laptopvideo2go.

hope that helps. I'm convinced it's that you have a driver loading that says your card doesn't support cuda even though it does.

  • The driver is CUDA enabled and I've added the results obtained from the deviceQuery test from the code samples. Is this what you were referring to? Dec 8 '10 at 17:22
  • edited to add a link to a discussion on this topic...ultimately i think it's a busted driver...i would try the one they reference on laptopvideo2go. some with similar problems have gotten this card running with it. Dec 8 '10 at 18:00
  • and yes, you provided exactly the info i was looking for Dec 8 '10 at 18:14
  • Thanks a lot for the link. Although I couldn't find any succesful attempts there but I'll keep trying :) They seem to use TCC mode for non Tesla cards, if that can be run, maybe even running CUDA via Remote Desktop might be possible. Dec 9 '10 at 13:21
  • Yes, the thread relates to tesla mode, but the point I was trying to get at is that it is possible with an unused video card and cuda processing. You output states that either there isn't a cuda card present or there is a version mismatch. I would go with the patched drivers, at least as a test, to see if they cause the card to be detected Dec 9 '10 at 13:24

Is a display plugged into it? I know for the ATI, you have to have a monitor plugged into each graphics card to use them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.