I've just ran into an issue where an admin user can log into his account but once logged in and a password is somehow required, OS X says he's using the wrong password. The password doesn't have any weird characters, it's a low security password.

  1. I've tried to boot from the install disk and reset the password, didn't work.

  2. I've checked the permissions and repaired them, didn't work.

  3. I've checked the disk, it was fine.

I'm really lost here, seems like the passwords are messed up in OS X, anyone have any idea how to fix this?


  • Did you create a new admin account, log in as that user, reset the first user's account, restart and try again? – user3463 Dec 8 '10 at 21:21
  • @Arjan: The password doesn't have any weird characters, it's a low security password ;) – scaron Dec 8 '10 at 21:28
  • @Randolph: I didn't try that, I'll give it a try. Thanks! – scaron Dec 8 '10 at 21:29
  • @Arjan: Yes that message is only shown when it's needed. I tried creating a new user ar suggested by Randolph, thing is, to create a new user, I need to "unlock" the User settings to be able to and my password doesn't work. – scaron Dec 8 '10 at 21:40
  • Make that second account an administrator, then you can use that account's password to unlock. – Daniel Beck Dec 9 '10 at 3:05

Check keyboard layout. My system is Dvorak, selected during installation. If I create a new user, and they use QWERTY, sometimes the password dialog pops up in the system keyboard layout, not the current user layout.

  • German layout is QWERTZ, French is AZERTY, Italian does weird things with the number row -- it doesn't have to be as "extreme" as Dvorak to mess with password input. – Daniel Beck Dec 9 '10 at 3:07

Run Keychain First Aid.

If the password he is using for this doesn't allow him to do it, have him use his previous password to run it.

If that doesn't work delete the login Keychain for the user, log out and back in and go run Keychain First Aid from there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.