5

I'm using VMWare. My host machine has internet connection. I have selected NAT in the virtual machine settings. What else do I need to do to get internet connection in virtual machine.

  • Is there any specific services to run in Host for NAT to work? – darthvader Aug 12 '09 at 21:42
  • What is your host OS? – Chris W. Rea Aug 21 '09 at 16:15
  • VMWare's installer had created two virtual network adapters. but,i had disabled them.how to get it back? – user38094 May 24 '10 at 0:20
  • After selecting NAT you still need to share your host network to your NAT VMnet. You can do that from Network and Sharing Center. Follow steps from this tutorial youtube.com/watch?v=H2j3nyl4muQ – Luzan Baral Aug 31 '17 at 18:20
4

I don't know your situation, but try a bridged connection.

3

To get the Internet connection working on the Virtual Machine:

  1. Click VM from menu bar
  2. Click Setting
  3. Click Network Adapter
  4. In Network Connection choose Custom:Specific virtual network and then choose VMnet0 (auto bridging)
  • Someone commented in a (hopefully) deleted answer that this also worked after upgrading Windows 8 to 10. – Arjan Aug 13 '15 at 16:23
2

First, I'm assuming you're talking about VMWare Workstation or VMWare Player, and not VMWare Server (free edition.)

In response to your 'any specific services to run in Host for NAT to work?' addition to the question, yes, there are services directly related to NAT. You should have a VMWare NAT and VMWare DHCP service. Both must be running for NAT to work properly. I may be wrong, but I believe the VMWare Authorization Service must be running as well.

Also, make sure your guest's network settings are set to use DHCP. When you have the VM configured to use NAT, VMWare will answer the DHCP request. If you have your VM configured to use a bridged connection, you must have a DHCP server on your real local network that will give the guest an IP.

One last thing, VMWare's installer will have created two virtual network adapters. Make sure you haven't disabled them. Your guest 'reaches' through these.

Ok, ONE last thing: Remember that a NAT'd VM will appear, to the rest of the world, as your host machine. A bridged VM will appear as a true host to the rest of the world. Depending on your network environment, this can cause issues. For example, here at work, the network is configured such that a MAC address is tied to a network port in the wall. ie: I can not unplug my desktop from the wall and connect my laptop, nor can I plug my desktop into a different network port. As such, I can not use bridged VMs. Because a bridged VM appears as a true host on the network with it's own MAC address, my bridged VMs packets are denied at the switch.

1

Just try to use diagnostic on connection in windows (in WM). It is solves problem by it self. It helped me in my case.

0

Nat sometimes comes up with weird results.

Try Bridged connection and if you have a DHCP server, it should automatically assign a DHCP lease and you should have an active internet connection.

0

You should be able to get an internet connection via NAT or bridged. Have you installed VMWare Tools in your VM? I usually can't get any connection until I do.

  • Yes I have installed VMWare tools – darthvader Aug 13 '09 at 5:35
0

You need to have both adapters enabled in VMware If you want to create a network one should be set on the team and one on NAT with the host

0

I have installed Windows 8 on virtual PC and enabled NAT Connection. All fine, but i had no Internet connection. All possible solutions tested, but not luck. After this i have looked in my network state and it looks like so:

enter image description here

DNS-Server address was wrong! I have opened my network settings in changed DNS-Server address from auto to manual, entered IP-Address from my Router and woops, it work's.

enter image description here

enter image description here

-3

I had the same problem with my linux virtual machines over vmware, using NAT.

The soluction was, in the networks connections of Windows ( conection Vnet8 ), right button --> Diagnose. Regards,

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.