Possible Duplicate:
Can't copy and paste in Remote Desktop Connection session

Recently I have been working with Remote Desktop Connection. I use it to access a virtual machine implemented through Hyper-V.

I have had many problems with the simple operation of cut-and-paste from my machine to the virtual one. The link between my clipboard and the remote clipboard is often broken. It is usual that this happens, when I copy/cut in the remote machine and then copy in my computer and then paste in the remote machine,

How do I fix this?

  • 1
    "it is known that this can be done" - still does not make it a programming question.
    – leppie
    Dec 1, 2008 at 12:48
  • I have erased C# tag (this is because i work with visualstudio, and i thought would interest people developing with this tool) but it is about remote-desktops and problems you can have programming. in fact, SO has a remote-desktop tag and the questions are of this type.
    – netadictos
    Dec 1, 2008 at 12:52
  • Incredible, 12 years later this issue still hasn't been solved by Microsoft. Nothing helps, I have to close the RDP connection and log in again, only this solves the problem. Also, on a German keyboard suddenly the special characters stop working. Again, only restarting the RDP connection fixes this. Shame on you Microsoft! Jan 14, 2021 at 14:47

2 Answers 2


I have learnt how to solve it from this article:

http://brennan.offwhite.net/blog/2007/01/18/fixing-copypaste-for-remote-desktop-sessions/ (This link has died, so I've updated it to point to an archive.org snapshot. -ed.)

To make it short: You have to stop the application called rdpclip.exe in your remote machine. Then you go to Run, and write rdpclip.exe to restart this app. The link between the clipboards is recovered.

Reason: The clipboard implements what is called " clipboard viewer chain " and is application-controlled, that is to say, that every application that is added to this chain is responsible of passing on notification messages to the next viewer in the chain, there are apps that don't pass the messages and this causes the problem (in Vista is solved).

(there is a wider explanation here: http://blogs.msdn.com/ts/comments/1089729.aspx )

  • Under Windows 7 I have also experienced rdpclip.exe process just stopping right in the middle of copy/pasting data to/from my session.
    – glenneroo
    Jan 23, 2011 at 20:37
  • hi the first link does not work please can you update the answer from 2008
    – shareef
    Aug 31, 2014 at 12:16
  • As Pops says in his edition, it can be recovered, accessing to the internet time machine: web.archive.org/web/20081022221455/http://brennan.offwhite.net/…
    – netadictos
    Sep 2, 2014 at 9:20

I've had a similar problem where copy/paste stops working and I couldn't even copy & paste on my local machine while Remote Desktop (RDP) Sessions were running. If I shut down RDP sessions then copy/paste functionality returned so it definitely appeared linked to remote desktop connections.

I found I was still running RDP v5.1. I've now upgraded to RDP 6.0 from Microsoft download and it appears to have fixed the problem.

So have a try at upgrading RDP and it may resolve the problem for you as well.

  • could you supply the URL please?
    – netadictos
    Jun 17, 2009 at 19:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.