I found the Attachment Extractor that should do exactly what I want--to delete attachments from selected or all emails. Unfortunately, after installing it and restarting Thunderbird, it did not work for me. I selected a group of messages, some with attachments, and picked "Extract from selected messages" on the context menu. Nothing happens; no JavaScript errors. I have tried for a single email message, and for an entire mail folder with the same results. My AE settings include "delete attachment with normal Thunderbird code" and "notify me when all have been extracted". No other check boxes are enabled on the "after extraction" tab.

I attempted to post this question first on the author's bug tracker forum but I could not even register on his site to get a login. (I tried with two different email addresses.)

So my questions:

  • Is there something obvious I am overlooking with Attachment Extractor?
  • Or is there another tool that would accomplish this task?

My configuation: Attachment Extractor 1.3.5, Thunderbird 3.1.6, Windows 7.

2 Answers 2


I came back a day later with fresh eyes. I assumed the add-on worked and that I was missing something. My only goal was to delete attachments. But I thought perhaps it really wanted to save attachments as well. I found two settings to try: giving a default path to save attachments to (general tab >> default save path) and more signficantly disabling the saving of attachments (advanced tab >> attachment file saving >> disable saving). Setting the former made the add-on start working, doing a detach-and-save, while setting the latter then did a detach-only. Problem solved!


I've found that to have any function of Attachment Extractor to work is to specify a default save path... no matter what you are doing with the attachments (kinda awkward).

For future reference as well, if you are trying to save attachments automatically, Attachment Extractor does not like it when multiple emails come in at the same time with attachments... the add-on gets confused and only extracts one of the attachments.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .