I have two keyboard languages, Swedish and American English. Normally, I switch language by hitting [alt]+[shift] and it works like a charm.

However, suddenly Microsoft Outlook has started to hang whenever I try to switch keyboard input language. Whenever i hit [alt]+[shift] or use the menu to switch language Outlook will hang indefinitely not responding.

Why? and what can I do about it?

I have English Windows 2000 and Outlook 2003 with the Google Search Desktop plugin.

  • Solved after having the problem for a year, and suddenly getting the correct answer on a 3 month old question. :D – Hugo Nov 11 '09 at 12:03

Actually, if you recently installed the Microsoft Office Connector to access your Hotmail accounts, you'll have this problem. Unfortunately, you have to get rid of it in order to fix your Outlook. So far I haven't found workaround.

| improve this answer | |
  • Thank you, thank you, thank you! The other answers where good, but did not solve my problem. Yours did! (Although, I didn't really have an outlook connector but an IMAP one.) – Hugo Nov 11 '09 at 12:03

My first guess would be a bad addin. If it's a brand name computer you often have several Office addins that you don't know about.

To test if any of these are causing your problem go to Start, Run and type Outlook /safe and click Ok. Now try to create an email and switch the input language. If it works it's most likely a bad addin.

To disable com addins that's causing trouble you go to Tools, Options, Other, Advanced, Com Addins and remove everything from the list.

| improve this answer | |

If you haven't tried it already, run a "Repair." Also try to remember anything you have installed or uninstalled recently before the problem occurred. But I would go with my first suggestion.

| improve this answer | |

if you install Outlook Connector 14.0 or later, you will have no issues with this. Thank you, gS

| improve this answer | |

Tried everything mentioned above none worked.

On another blog I found the cure :

Download connector beta version 14.1, not the standard 12.1 - doesn't do anything.

14.1 beta version solved the problem without me having to delete or uninstall anything

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.