34

I have a networked drive mapped to "U:\"

I want to go to that drive from a command line.

However, when I try I get an error

C:>u: The system cannot find the drive specified.

How do I do that? Can I? Is there some Environmental setting I need to do?

4 Answers 4

54

You need to make sure that the drive is mapped under the user which is running the command prompt. Try typing net use U: and see what info it gives you. If it's not showing the drive as being mapped, try remapping the drive (net use U: \\servername\share\path\).

You can also try changing directories by using cd /d U:, rather than just U:. This won't help you though if the network path doesn't exist.

4
  • 1
    it is mapped but still not working when I use cd Jul 12, 2019 at 20:05
  • Perfect answer.! very easy to use shared drives now. Nov 8, 2019 at 10:41
  • To think I was once very comfortable with this... so weird coming back after 10 years with mac/linux
    – Matt M.
    Sep 24, 2022 at 2:33
  • I've run into a problem where elevated prompts don't recognize my mapped drives. I tried remapping as you said, but this overrode my currentuser's mapping for that drive letter; therefore, after a restart, I had to remap again. this makes it extremely inconvenient to "run as administrator" for executables in the network share since I either need to break then fix my mapping, or navigate to the file without using the drive letter mapping. Any ideas on that? Your answer helped, but it was only part of the answer for my situation. (wonder if this is something new w/ win11 or just UAC stupidity?) Nov 1, 2022 at 0:21
5

CD if in the user account where drive is mapped.If you are in a Elevated Command you are no longer in the mapped user account.

Win 7: net use U: \servername\share\path\

win 8: pushd \servername\share\path\

1
  • Weirdly I am on Windows 7 but it's pushd not net use. Maybe because of some update/patch?
    – Hack-R
    May 24, 2017 at 18:37
4

In case you're using Windows 8 the pushd command will help you

pushd u:

Source: How to cd to a network drive on Windows 8?

2
  • why was this downvoted?
    – wizlog
    Jul 26, 2017 at 22:35
  • This is what I was trying to remember, thank you very much!
    – jacktrader
    Sep 7, 2022 at 14:31
0

Windows PowerShell in Administrator mode will allow you to perform MS-DOS Commands you are looking for.

Open Windows PowerShell... Type CD ...

Ex.

PS C:\> CD U:\

PS U:\>

Hope that helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .