I am setting up a development environment for the latest Android 2.3 on a fresh install of Windows 7 64-bit.

I first installed the 64-bit JDK 6 (jdk-6u23-windows-x64.exe). Then, I installed 64-bit Eclipse Classic 3.6 (eclipse-SDK-3.6.1-win32-x86_64.zip). Then, I proceed to install the Android SDK Starter Package: installer_r08-windows.exe.

But... upon start it says: "Java SE Development Kit (JDK) not found."

Why? I just installed it.

Is this a mismatch between 32-bit and 64-bit?

How do I solve this?

Update (1): I tried setting the %JAVA_HOME% environment variable, as well as setting the Installed JREs in Eclipse, as suggested below. None of these solved the problem.

It appears that I am not the only experiencing the problem, as this thread suggests: https://stackoverflow.com/questions/1919340/android-sdk-setup-under-windows-7-pro-64-bit

I wonder whether there is a 64-bit version of the Android SDK.

Update (2): I used the zip version instead (android-sdk_r08-windows.zip), ran android.bat, updated all SDK packages, and installed the ADT plugin (8.0.1), not before having to check: 'Contact all update sites during install to find required software'.

We'll see how this goes...

Update (3): It worked! (going to accept @bubu's answer shortly) -- but why doesn't the emulator include the HelloAndroid app when I run it (Ctrl+F11) from Eclipse?

4 Answers 4


I guess this may be a glitch in the latest version of the Android SDK.

You can try to download the '.zip' version of the Android SDK, run sdk manager.exe and let it update. Then you install the Android development platform (Android Development Tools (ADT) plugin) for Eclipse accordingly and point to the directory in the preferences.

  • @bubu Thanks (and +1). I am not sure whether this is going to be the complete solution but I unzipped android-sdk_r08-windows.zip to C:\android-sdk-windows, appended C:\android-sdk-windows\tools to %PATH% in System env vars and tried to install the ADT plugin from within Eclipse. The installation of the ADT plugin failed with "...requires 'org.eclipse.gef 0.0.0' but it could not be found". I then tried running "SDK Manager.exe" as you suggested but it forces me to install ALL SDK platform versions ( from 1.5 to 2.3). Is there a way to ask it to install only 2.3? Dec 14, 2010 at 16:22
  • I think the correct way would be installing all sdk platform versions. As an android developer, you don't want to develop for the latest API level unless it is absolutely necessary. Android is backward compatible - you can run an application compiled for android 1.6 on 2.3 but not vice versa. and more importantly, you have to run sdk manager.exe to download the sdk before you install the ADT plugin. check the android SDK website for tutorial.
    – bubu
    Dec 14, 2010 at 16:25
  • @bubu, OK. I am still in the beginning of learning Android dvelopment and I didn't want to distract myself with more than one version. But "SDK Manager.exe" doesn't let me anyway, so I will go with that. Dec 14, 2010 at 16:30
  • anyways, do take my advice and use the old API levels so that you can actually run your program on an android machine. as far as I know there is no android 2.3 machines out yet, and running the just written application on a real android machine is much more joyful than on the cold, unresponsive emulator.
    – bubu
    Dec 14, 2010 at 16:33
  • @bubu Uh Oh... I did exactly as you said but I am still getting the error (of not being able to install the ADT plugin): "(com.android.ide.eclipse.adt.feature.group 8.0.1.v201012062107-82219) requires 'org.eclipse.gef 0.0.0' but it could not be found" -- any idea how to proceed from here? Dec 14, 2010 at 17:11

From one of the links:

When there’s a pop up say JDK not found. just press ‘back’ button and then press again ‘next’ button..

This works! The second time it finds it!


According to Android SDK installation doesn't find JDK the installer only knows to look for the 32-bit JDK.


The first thing I'd try: set the JAVA_HOME system variable. It seems like many Java development applications look for this.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .