I recently encountered a virus that some how disabled my computer from seeing a few USB flash drives that were inserted into its USB slot. I know the USB slots work because I have tried with other devices, mice,ect...

I am 100% sure my computer is clean. So I assume to problem lies with the flash drive itself. I think if I can use a disk manager on it I can reformat the drive, thus erasing what ever is on it. I am using windows vista 32-bit.

I have seen similar questions on this but the only fixes require the computer so see the drive.

Question is this, how can I force my computer to "talk" to something it can't see? Disk manager only appears with drives that it can see. Is there a way to specify a USB port to attempt a connection. For instance "mount" USB port # X. Since this problem keep reoccurring I need a technical fix not a "put the flash drive in a ___ to erase that data and start again."

Will not mount on any computer or OS I have tired, Windows, Linux, Ubuntu, Mac

  • 1
    Will it mount through let's say, the Ubuntu LiveCD? – BloodPhilia Dec 14 '10 at 17:04

I approach this problem from the live media perspective....given that you are SURE that your base drive is clear and that formatting is okay, that means that USB regkeys disabling a particular device do not exist and that using gparted to kill everything on the disk is okay. If this is the case, I would look at attaching the device to a running live distro of linux and using gparted to reformat the partition. If the drive just fails to recognize, I would look into plugging it in to different USB ports...a problem I have seen in windows distributions before.

  • I am sure the base drive is clean, and I know that the formatting is correct as I used it before it "died". I have tried all the slots I have, 4 on the case plus the 2 on the Asus mobo, nothing changed. The recognition is the problem so a work around is required. – allindal Dec 14 '10 at 17:24

See I Can Not Find My USB Drive In Vista.

It discusses the case where the drive letter assigned to that USB device is for some unknown reason already is in use, so it doesn't show up in the list of drives.

  • This looked promising but when I reassigned all of my drive letters / removed all drives to leave only the c: and re named that, however nothing happened. Still doesn't apprear, but a logical approach on your part. – allindal Dec 15 '10 at 16:33
  • Do you see it in Drive Manager in any way ? Do you see an error in Device Manage? Have you rebooted? – harrymc Dec 15 '10 at 17:04

I can't really see if you said you formatted the usb drive. I'm not sure which drive you mean by base drive. Also, formatting doesn't just wipe the data. So it's good as a possible fix for your usb drive, to format it.

Format the USB drive again. The file system on it could've been messed up..

You can format it as FAT32 or NTFS... (that's choosing the file system)

You can do the format from windows, right click the usb drive in "my computer" and choose format... try ntfs or fat32, do ok.

  • maybe you missed the crux of the problem, I cannot get the computer to recognize the drive, hence your solution of clicking on it doesn't apply. "disabled my computer from seeing a few USB flash drives" – allindal Dec 15 '10 at 16:21
  • So you don't even get a drive letter listed. It's worth doing some basic troubleshooting to narrow things down a bit more confidently.. do you have any other usb sticks even small ones, from before the virus issue.. Any luck with those? How about the usb sticks that aren't working in your computer, are they working in another or other computers. There could perhaps be some strange BIOS setting causing it to work for USB mouse but not for a USB disk drive. We don't know what mechanism the virus would've used to have caused this problem.So don't know it is the virus. it is still a big mystery. – barlop Dec 16 '10 at 9:38
  • A USB HDD would be interesting to try, since it gets its power externally.. so if that works it suggests it may be an issue powering usb disk drives. When you try a different OS and it fails, and the USB sticks work in other computers, it suggests either Hardware issue of your computer(usb ports or power to them/psu issue), or a BIOS setting. But to have mice ok but not disk drives.. v strange 'cos i'm not familiar with a BIOS setting issue that'd cause that though could be. Make sure anything USB e.g. USB Legacy is on. – barlop Dec 16 '10 at 9:44

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.